Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-17003

ci_hsc tests (may) not have correct linker environment on macOS

    Details

    • Type: Bug
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: ci_hsc
    • Labels:
      None

      Description

      This is a probable regression introduced in DM-16819, when I tried to re-enable the test_import.py script in SCons (it looked like it was supposed to be run, but wasn't because the SConstruct wasn't talking to the SConscript because ci_hsc doesn't really use sconsUtils).

      The causality was masked by a transient known download bug in Astropy.

        Attachments

          Activity

          jbosch Jim Bosch added a comment -

          Preferred fix worked.  Merged to master without review as the fix is trivial, master is already broken, and most people are now on some kind of holiday break.


            People

            • Assignee:
              jbosch Jim Bosch
              Reporter:
              jbosch Jim Bosch
              Watchers:
              Eli Rykoff, Jim Bosch
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Summary Panel