Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-17088

Fix collections import deprecation warning in python 3.7

    Details

    • Templates:
    • Story Points:
      0.5
    • Sprint:
      Arch 2019-01-07
    • Team:
      Architecture

      Description

      In python3.7 these warnings turn up:

      DeprecationWarning: Using or importing the ABCs from 'collections' instead of from 'collections.abc' is deprecated, and in 3.8 it will stop working

      pex_config and daf_persistence are known to have the problem.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                tjenness Tim Jenness
                Reporter:
                tjenness Tim Jenness
                Reviewers:
                Kian-Tat Lim
                Watchers:
                Kian-Tat Lim, Tim Jenness
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel