Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-1710

ValueError in lsst.afw.table.Catalog.extend()

    XMLWordPrintable

Details

    • Story
    • Status: Done
    • Resolution: Done
    • None
    • afw
    • None

    Description

      from lsst.afw.table import BaseCatalog, Schema
       
      s = Schema()
      c1 = BaseCatalog(s)
      c2 = BaseCatalog(s)
       
      c1.extend(c2)

      The above fails, saying:

      Traceback (most recent call last):
        File "test.py", line 7, in <module>
          c1.extend(c2)
        File "/Users/jds/Projects/Astronomy/LSST/stack/DarwinX86/afw/10.0+3/python/lsst/afw/table/tableLib.py", line 6909, in extend
          _tableLib.BaseCatalog_extend(self, iterable, deep)
      ValueError: invalid null reference in method 'BaseCatalog_extend', argument 3 of type 'lsst::afw::table::SchemaMapper const &'

      Attachments

        Issue Links

          Activity

            No builds found.
            swinbank John Swinbank created issue -
            swinbank John Swinbank made changes -
            Field Original Value New Value
            Watchers John Swinbank [ John Swinbank ] Dominique Boutigny, Jim Bosch, John Swinbank [ Dominique Boutigny, Jim Bosch, John Swinbank ]

            Ready for review on tickets/DM-1710.

            I created a new testBaseCatalog.py file for the test. This seems like a lot of boilerplate for a tiny test case and even more tiny bugfix, but there was nowhere else obvious to add a test and I'm naively hoping we might add more tests to this file in future. If you'd prefer that I just slip this test in somewhere else, though, that's fine with me.

            swinbank John Swinbank added a comment - Ready for review on tickets/ DM-1710 . I created a new testBaseCatalog.py file for the test. This seems like a lot of boilerplate for a tiny test case and even more tiny bugfix, but there was nowhere else obvious to add a test and I'm naively hoping we might add more tests to this file in future. If you'd prefer that I just slip this test in somewhere else, though, that's fine with me.
            swinbank John Swinbank made changes -
            Reviewers Jim Bosch [ jbosch ]
            Status To Do [ 10001 ] In Review [ 10004 ]
            jbosch Jim Bosch added a comment -

            I think this is a duplicate of DM-1514 (also in review), or at least a close relative. I'm going to try moving your test code over to that branch, to ensure it passes your test case, and if doesn't I'll move your fix as well. I'll probably put the test in testSimpleTable.py.

            jbosch Jim Bosch added a comment - I think this is a duplicate of DM-1514 (also in review), or at least a close relative. I'm going to try moving your test code over to that branch, to ensure it passes your test case, and if doesn't I'll move your fix as well. I'll probably put the test in testSimpleTable.py.
            jbosch Jim Bosch made changes -
            Link This issue duplicates DM-1514 [ DM-1514 ]
            jbosch Jim Bosch added a comment -

            Actually, it looks like while the two issues are closely related, neither change fixes the other's bug. Might as well just merge them to master separately, since we already have separate branches.

            I would recommend moving the test to testSimpleTable.py, however, as we've already got a lot of other similar tests there (essentially all the tests for BaseTable - perhaps the test should be renamed).

            jbosch Jim Bosch added a comment - Actually, it looks like while the two issues are closely related, neither change fixes the other's bug. Might as well just merge them to master separately, since we already have separate branches. I would recommend moving the test to testSimpleTable.py, however, as we've already got a lot of other similar tests there (essentially all the tests for BaseTable - perhaps the test should be renamed).
            jbosch Jim Bosch made changes -
            Status In Review [ 10004 ] Reviewed [ 10101 ]
            swinbank John Swinbank made changes -
            Link This issue duplicates DM-1514 [ DM-1514 ]
            swinbank John Swinbank made changes -
            Resolution Done [ 10000 ]
            Status Reviewed [ 10101 ] Done [ 10002 ]
            jbosch Jim Bosch made changes -
            Link This issue relates to DM-1083 [ DM-1083 ]
            swinbank John Swinbank made changes -
            Epic Link DM-1826 [ 15808 ]
            swinbank John Swinbank made changes -
            Issue Type Bug [ 1 ] Story [ 10001 ]

            People

              swinbank John Swinbank
              swinbank John Swinbank
              Jim Bosch
              Dominique Boutigny, Jim Bosch, John Swinbank
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Jenkins

                  No builds found.