Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-17399

Issue(s) with test_measure.py in meas_algorithms

    Details

    • Type: Bug
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: meas_algorithms
    • Labels:
      None
    • Templates:
    • Story Points:
      1
    • Sprint:
      AP S19-2
    • Team:
      Alert Production

      Description

      In the testFootprintsMeasure function in tests/test_measure.py in meas_algorithms, the test claims to "Check that we can measure the objects in a detectionSet". All of the "asserts" of the test occur within a loop over the sources in measCat (here). HOWEVER, when I run this test, I get 0 detections, so that loop is never entered and no assertions get made (which I noticed when I was not seeing any dots on the sources in ds9 when updating the display code). It seems that something is seriously amiss if we are expecting (it looks like at least 3) detections but getting 0.  (I also think I see this as the line

      measurement INFO: Measuring 0 sources (0 parents, 0 children)
      

      in Jenkins artifact files, e.g. here, so it's not just a local setup issue).

      Also, in the testDetection function, nothing is actually "asserted" in the function, so it seems that the "test" is that it does not crash when running through the operations? Would a check on a (minimum?) number of detections be appropriate here?

        Attachments

          Activity

            People

            • Assignee:
              swinbank John Swinbank
              Reporter:
              lauren Lauren MacArthur
              Reviewers:
              Lauren MacArthur
              Watchers:
              Jim Bosch, John Swinbank, Lauren MacArthur, Yusra AlSayyad
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Summary Panel