Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-17425

Investigate use of smaller patch sizes

    XMLWordPrintable

Details

    • Story
    • Status: Done
    • Resolution: Done
    • None
    • None
    • External

    Description

      Deep observations and improved sky subtraction combine to link detections over a large fraction of the coadd patches, which makes things difficult for the deblender, resulting in large memory usage and very long execution times.

      Ikeda-san is investigating the use of smaller patch sizes, which artificially truncates the blends. I have a patch for the deblender that does the same kind of thing there. We need to validate these approaches. We are especially concerned that we not degrade the photometry.

      Attachments

        1. det_compare_4k_2k_revisedDetection.png
          det_compare_4k_2k_revisedDetection.png
          3.32 MB
        2. fig_deltam_large1_position.pdf
          2.76 MB
        3. patchsize_2k4k-1.pdf
          525 kB
        4. patchsize_4k_2k_det.png
          patchsize_4k_2k_det.png
          2.10 MB
        5. patchsize_twocolor_v2.pdf
          237 kB
        6. patchsize_twocolor.pdf
          263 kB
        7. patchsize_v4.pdf
          589 kB
        8. patciszie_v5.pdf
          485 kB

        Issue Links

          Activity

            We also checked stellar sequence on the gri color-color diagram by using the cmodel magnitude. We confirmed that the scatter of 2k x 2k looks similar to that of 4k x 4k.

            patciszie_v5.pdf

            ikedahr Hiroyuki Ikeda added a comment - We also checked stellar sequence on the gri color-color diagram by using the cmodel magnitude. We confirmed that the scatter of 2k x 2k looks similar to that of 4k x 4k. patciszie_v5.pdf

            Previously, we found that some objects (~6.6%) have 

            delta_m (cmodel mag (4K) - model mag (2K))>1.0.

            patchsize_2k4k-1.pdf

            We also check the footprint for 4K and 2K (delta_mag>1mag) to study why delta_m > 1. As shown in 3page of the above pdf file, the footprint looks same.

            But, modelfit_CModel_ellipse_{xx,yy,xy} for 2K > 100.

            ikedahr Hiroyuki Ikeda added a comment - Previously, we found that some objects (~6.6%) have  delta_m (cmodel mag (4K) - model mag (2K))>1.0. patchsize_2k4k-1.pdf We also check the footprint for 4K and 2K (delta_mag>1mag) to study why delta_m > 1. As shown in 3page of the above pdf file, the footprint looks same. But, modelfit_CModel_ellipse_{xx,yy,xy} for 2K > 100.

            We are still discussing. Because we just noticed that the detected sources around bright sources for 2k is somewhat different from the 4k. Therefore, we will check the difference of the detected sources around bright sources for 2k and 4k when we apply the revised detection algorithm that is made by mineo-san.

            ikedahr Hiroyuki Ikeda added a comment - We are still discussing. Because we just noticed that the detected sources around bright sources for 2k is somewhat different from the 4k. Therefore, we will check the difference of the detected sources around bright sources for 2k and 4k when we apply the revised detection algorithm that is made by mineo-san.
            ikedahr Hiroyuki Ikeda added a comment - - edited

            We checked the difference of the detected sources around bright sources for 2k and 4k when we apply the revised detection algorithm that is made by mineo-san.

            WE confirmed that detected sources around bright sources for 2k is slightly different from the 4k even if we apply the revised detection algorithm that is made by mineo-san.

             

            In addition, we will check the difference of the detected sources after the sky subtraction algorithm is improved.

            ikedahr Hiroyuki Ikeda added a comment - - edited We checked the difference of the detected sources around bright sources for 2k and 4k when we apply the revised detection algorithm that is made by mineo-san. WE confirmed that detected sources around bright sources for 2k is slightly different from the 4k even if we apply the revised detection algorithm that is made by mineo-san.   In addition, we will check the difference of the detected sources after the sky subtraction algorithm is improved.

            Investigation was performed and the conclusion was to not use smaller patch sizes for the data release. Closing this as Done

            yusra Yusra AlSayyad added a comment - Investigation was performed and the conclusion was to not use smaller patch sizes for the data release. Closing this as Done

            People

              ikedahr Hiroyuki Ikeda
              price Paul Price
              Hiroyuki Ikeda, Masayuki Tanaka, Paul Price, Yusra AlSayyad
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Jenkins

                  No builds found.