Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-17737

RangeError: 'Unexpectedly large transform passed to WarpedPsf'

    XMLWordPrintable

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Story Points:
      1
    • Sprint:
      DRP S19-3
    • Team:
      Data Release Production

      Description

      With w_2019_04 lsst_distrib and master obs_lsst at the time, "RangeError" is seems in makeCoaddTempExp in several tracts of imsim DESC Run 1.2i data. An example to reproduce is:

      makeCoaddTempExp.py  /datasets/DC2/repo/ --rerun w_2019_04/sfm:private/username/yours -c doApplyUberCal=False --id tract=4432 patch=4,5 filter=g   --selectId visit=183892
      

      which gives:

      makeCoaddTempExp INFO: Processing calexp 1 of 1 for this Warp: id=DataId(initialdata={'visit': 183892, 'filter': 'g', 'raftName': 'R34', 'detectorName': 'S12', 'detector': 158, 'tract': 4432}, tag=set())
      makeCoaddTempExp.warpAndPsfMatch.psfMatch INFO: compute Psf-matching kernel
      makeCoaddTempExp.warpAndPsfMatch INFO: Cannot PSF-Match: 
        File "src/WarpedPsf.cc", line 72, in lsst::geom::Box2I lsst::meas::algorithms::{anonymous}::computeBBoxFromTransform(lsst::geom::Box2I, const lsst::geom::AffineTransform&)
          Unexpectedly large transform passed to WarpedPsf {0}
      lsst::pex::exceptions::RangeError: 'Unexpectedly large transform passed to WarpedPsf'
       
      makeCoaddTempExp INFO: directWarp has 349480 good pixels (2.0%)
      makeCoaddTempExp INFO: psfMatchedWarp has 0 good pixels (0.0%)
      makeCoaddTempExp INFO: Persisting deepCoadd_directWarp
      

      FWIW, this wasn't seen in last year's processing using w_2018_49.

        Attachments

          Issue Links

            Activity

            swinbank John Swinbank added a comment -

            Yusra AlSayyad, Jim Bosch — again, I guess this is a DRP issue. Shout if you disagree.

            yusra Yusra AlSayyad added a comment - - edited

            The w_2019_04 simply had a bad WCS. In fact, this WCS is HILARIOUS and I'm calling dibs on it for an avatar. If you warp the calexp to the SkyMap WCS (with no patch bbox), this is the result. Is that corner folding in on itself!?
            w_2019_04/sfm:private/yusra/test_wcs/w_2019_06_warp:

            Curiously, this problem has fixed itself with w_2019_06.
            private/yusra/test_wcs/w_2019_06:private/yusra/test_wcs/w_2019_06_warp_new:

            I vote we close this, noting that when we return to pair coding DM-16301, the calexp with the bad wcs would have never been written out.

            One more piece of info: If you blink the good and bad calexps with locked wcs in ds9, it looks just like a translation with nothing crazy: ds9 -zscale /datasets/DC2/repo/rerun/w_2019_04/sfm/calexp/00183892-g/R34/calexp_00183892-g-R34-S12-det158.fits /datasets/DC2/repo/rerun/private/yusra/test_wcs/w_2019_06/calexp/00183892-g/R34/calexp_00183892-g-R34-S12-det158.fits

             

            yusra Yusra AlSayyad added a comment -

            If you want evidence that the WarpedPsf is happy, it logs:

            makeCoaddTempExp INFO: Processing calexp 1 of 1 for this Warp: id=DataId(initialdata={'visit': 183892, 'filter': 'g', 'raftName': 'R34', 'detectorName': 'S12', 'detector': 158, 'tract': 4432}, tag=set())
            makeCoaddTempExp.warpAndPsfMatch.psfMatch INFO: compute Psf-matching kernel
            makeCoaddTempExp.warpAndPsfMatch.psfMatch INFO: Adjusted dimensions of reference PSF model from (23, 23) to (53, 53)
            makeCoaddTempExp.warpAndPsfMatch.psfMatch INFO: Psf-match science exposure to reference
            makeCoaddTempExp.warpAndPsfMatch.psfMatch INFO: done
            makeCoaddTempExp INFO: directWarp has 147435 good pixels (0.8%)
            makeCoaddTempExp INFO: psfMatchedWarp has 135641 good pixels (0.8%)
            makeCoaddTempExp INFO: Persisting deepCoadd_directWarp
            makeCoaddTempExp INFO: Persisting deepCoadd_psfMatchedWarp
            

            yusra Yusra AlSayyad added a comment - - edited

            Marking Done because (1) it's fixed and (2) throwing a RangeError is the behavior we wanted (unlike DM-17731)


              People

              Assignee:
              yusra Yusra AlSayyad
              Reporter:
              hchiang2 Hsin-Fang Chiang
              Watchers:
              Hsin-Fang Chiang, John Swinbank, Yusra AlSayyad
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: