Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-18067

Add fluxMag0 PhotoCalib factory function

    XMLWordPrintable

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: afw

      Description

      While working on DM-10156, I found that it would in fact be useful to have a factory function that took the Calib-style fluxMag0/fluxMag0Err and returned a PhotoCalib. I implemented it on that ticket, but it stands alone, so I'm going to cherry-pick it here to save the poor reviewer of DM-10156 a little bit of effort.

        Attachments

          Issue Links

            Activity

            Hide
            Parejkoj John Parejko added a comment -

            Thank you for the review.

            Merged and done.

            Show
            Parejkoj John Parejko added a comment - Thank you for the review. Merged and done.
            Hide
            krzys Krzysztof Findeisen added a comment -

            Please don't say "C++ overload convention", I'm pretty sure there's no such rule. for giving a descriptive name, otherwise minor comments.

            Show
            krzys Krzysztof Findeisen added a comment - Please don't say "C++ overload convention", I'm pretty sure there's no such rule. for giving a descriptive name, otherwise minor comments.
            Show
            Parejkoj John Parejko added a comment - Jenkins run: https://ci.lsst.codes/blue/organizations/jenkins/stack-os-matrix/detail/stack-os-matrix/29463/pipeline
            Hide
            Parejkoj John Parejko added a comment -

            Krzysztof Findeisen, would you be willing to review this ~50 line change? I pulled it out of DM-10156 to make that one a bit more tractable.

            One question I have is whether we should follow the C++ overload convention, or whether I should rename the new function to e.g. makePhotoCalibFromZeroPoint() to make the intention clearer in python (where it would primarily be used)?

            Show
            Parejkoj John Parejko added a comment - Krzysztof Findeisen , would you be willing to review this ~50 line change? I pulled it out of DM-10156 to make that one a bit more tractable. One question I have is whether we should follow the C++ overload convention, or whether I should rename the new function to e.g. makePhotoCalibFromZeroPoint() to make the intention clearer in python (where it would primarily be used)?

              People

              Assignee:
              Parejkoj John Parejko
              Reporter:
              Parejkoj John Parejko
              Reviewers:
              Krzysztof Findeisen
              Watchers:
              Jim Bosch, John Parejko, John Swinbank, Krzysztof Findeisen
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  CI Builds

                  No builds found.