Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-19412

Bad CCD rotations in visualizeVisit.py

    XMLWordPrintable

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: afw, pipe_drivers
    • Labels:
      None
    • Story Points:
      1
    • Sprint:
      DRP S19-5
    • Team:
      Data Release Production

      Description

      Something seems to be going wrong in the application of NQUARTER in visualizeVisit.py (maybe it's being applied twice, or maybe not at all).  Lauren MacArthur suspects this was broken in DM-19371, and that the fix involves the new obeyNQuarter clause: https://github.com/lsst/afw/commit/f154d3474b433e269d65c697c02cd1738e918942

        Attachments

          Issue Links

            Activity

            rhl Robert Lupton added a comment -

            The problem is that the code in visualizeVisit fails to take account of nQuarter at all.  In the longer run we should probably remove it and use the code from afw.cameraGeom directly (although that would involve more I/O).  In the short term I have a fix.

            I think we didn't see this because no-one looked; I think that the problem was present ever since we stopped rotating int the ISR.  The DM-19371 fix is related (it fixes the raw files that need a callback, but all other file types were already correct)

            rhl Robert Lupton added a comment -

            merged and pushed


              People

              Assignee:
              jbosch Jim Bosch
              Reporter:
              jbosch Jim Bosch
              Reviewers:
              Jim Bosch
              Watchers:
              Jim Bosch, Robert Lupton
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  CI Builds

                  No builds found.