Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-19477

Double-check stabilized calibration conjecture of DM-19328

    XMLWordPrintable

Details

    • Story
    • Status: Done
    • Resolution: Done
    • None
    • None
    • None
    • 1
    • Data Release Production
    • No

    Description

      The investigation of DM-19328 resulted in a narrative explaining the small differences observed in recent reprocessing-to-reprocessing calibrations as being due to recent churn in the matcher.   This was followed by the speculation that assuming things have settled down in the matcher tweaking, we will not see any difference between the current w_2019_14 and the next reprocessing, presumably w_2019_18.

      This ticket is to check this conjecture when the next RC2 reprocessing becomes available.

      Attachments

        Issue Links

          Activity

            Keep in mind that erykoff notes in DM-19328 that there may be some small changes introduced by DM-10800 and DM-19304.

            lauren Lauren MacArthur added a comment - Keep in mind that erykoff notes in DM-19328 that there may be some small changes introduced by DM-10800 and DM-19304 .
            lauren Lauren MacArthur added a comment - - edited

            This somewhat ancient ticket kept getting put off due to a never-ending stream of small changes that resulted in continued small calibration differences.  To isolate the issue (as in the description) to the matcher, the comparison is more easily made with the DC2/imsim processing (which does not include fgcm or jointcal which do continue to see updates). I can confirm that the photometric and astrometric calibrations between the past 3 DC2 processing runs have held perfectly stable (so between w_2021_44 vs. w_2021_40 vs. w_2021_36, but w_2021_36 vs. w_2021_32 did have small differences due to DM-31412 landing in w_2021_34).  All comparison plots can be perused following the links provided in the run tickets: DM-32706, DM-32071, DM-31665.

            lauren Lauren MacArthur added a comment - - edited This somewhat ancient ticket kept getting put off due to a never-ending stream of small changes that resulted in continued small calibration differences.  To isolate the issue (as in the description) to the matcher, the comparison is more easily made with the DC2/imsim processing (which does not include fgcm or jointcal which do continue to see updates). I can confirm that the photometric and astrometric calibrations between the past 3 DC2 processing runs have held perfectly stable (so between w_2021_44 vs. w_2021_40 vs. w_2021_36 , but w_2021_36 vs. w_2021_32 did have small differences due to DM-31412 landing in w_2021_34 ).  All comparison plots can be perused following the links provided in the run tickets: DM-32706 , DM-32071 , DM-31665 .

            Example plots of the flatline inter-run comparison for photometric and astrometric measures:

            lauren Lauren MacArthur added a comment - Example plots of the flatline inter-run comparison for photometric and astrometric measures:

            When you get a chance, would you mind giving this a quick look to see if it makes sense?

            lauren Lauren MacArthur added a comment - When you get a chance, would you mind giving this a quick look to see if it makes sense?
            lskelvin Lee Kelvin added a comment -

            Thanks for making these checks Lauren. I've had the chance to take a closer look at these comparison plots, specifically, comparison visit plots. Coadd-level scatter/histogram plots still show some scatter, as might be expected. In particular, I've eyeballed all ~1100 visit-level plots in this w_2021_44 vs w_2021_40 comparison directory. I can confirm that every single visit-level plot shows a flatline trend, i.e., no difference at all between w44 and w40. Similar trends were noted when I compared several plots from w40 to w36. To that end, I think this confirms that any previously reported churn in the matcher now seems to be a distant memory, and appears to have settled down satisfactorily. Thanks again for looking into this, very nicely done!

            lskelvin Lee Kelvin added a comment - Thanks for making these checks Lauren. I've had the chance to take a closer look at these comparison plots, specifically, comparison visit plots. Coadd-level scatter/histogram plots still show some scatter, as might be expected. In particular, I've eyeballed all ~1100 visit-level plots in this w_2021_44 vs w_2021_40 comparison directory . I can confirm that every single visit-level plot shows a flatline trend, i.e., no difference at all between w44 and w40. Similar trends were noted when I compared several plots from w40 to w36 . To that end, I think this confirms that any previously reported churn in the matcher now seems to be a distant memory, and appears to have settled down satisfactorily. Thanks again for looking into this, very nicely done!

            Thanks for the above-and-beyond review!  Yes, the coadds are still seeing some churn, from me in particular on DM-30284, which will hopefully merge soon.

            lauren Lauren MacArthur added a comment - Thanks for the above-and-beyond review!  Yes, the coadds are still seeing some churn, from me in particular on DM-30284 , which will hopefully merge soon.

            People

              lauren Lauren MacArthur
              lauren Lauren MacArthur
              Lee Kelvin
              Eli Rykoff, Jim Bosch, Lauren MacArthur, Lee Kelvin, Yusra AlSayyad
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Jenkins

                  No builds found.