Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-19658

afw.cameraGeom.utils.makeImageFromCamera ERROR Dimension mismatch

    Details

    • Type: Story
    • Status: Invalid
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: Science Pipelines
    • Labels:
      None
    • Team:
      Data Release Production

      Description

      With w_2019_18, running skyCorrection.py with HSC data gave the following error:

      afw.cameraGeom.utils.makeImageFromCamera ERROR: Unable to fit image for detector "0_31" into image of camera:
        File "src/image/Image.cc", line 183, in void lsst::afw::image::ImageBase<PixelT>::assign(const lsst::afw::image::ImageBase<PixelT>&, const lsst::geom::Box2I&, lsst::afw::image::ImageOrigin) [with PixelT = float]
          Dimension mismatch: 522x256 v. 256x522 {0}
      lsst::pex::exceptions::LengthError: 'Dimension mismatch: 522x256 v. 256x522'
      

      This error didn't appear with the w_2019_14 stack.

      Besides detector "0_31", it also happened to detector "1_35" , detector "0_35", and detector "1_31" – the four edge CCDs that lay 90 deg different from others.

      An example to reproduce,

      skyCorrection.py /datasets/hsc/repo --calib /datasets/hsc/repo/CALIB --rerun  RC/w_2019_18/DM-19151-sfm:private/user/name --time 90  --id visit=34338 --cores 24 
      

        Attachments

          Issue Links

            Activity

            hchiang2 Hsin-Fang Chiang added a comment -

            Looks like the bug was introduced between w_2019_15 and w_2019_16.

            lauren Lauren MacArthur added a comment -

            I can confirm that running:

            skyCorrection.py /datasets/hsc/repo --calib /datasets/hsc/repo/CALIB --rerun  RC/w_2019_18/DM-19151-sfm:private/lauren/DM-19658  --time 90  --id visit=34338 --cores 24
            

            with master pipe_drivers runs to completion and produces calexp-camera-34338.fits:

            hchiang2 Hsin-Fang Chiang added a comment -

            Thanks Lauren MacArthur!

            Mark this ticket Invalid as it has been fixed already.


              People

              • Assignee:
                Unassigned
                Reporter:
                hchiang2 Hsin-Fang Chiang
                Watchers:
                Hsin-Fang Chiang, Lauren MacArthur
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: