Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-19682

Fix DAYOBS calculation and allow for gen2 header correction for ingest

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: obs_lsst
    • Labels:
      None

      Description

      Robert Lupton reported that the gen2 butler dayObs quantity is not being calculated correctly. It is always assumed to be calculated from the date and not from the DAYOBS header. This needs to be fixed to only use the date if DAYOBS is missing.

      Additionally, since this is a gen2 ingest model parameter and not part of the gen3 data model, the value does not get corrected if there is a FITS header correction file. Update ingest so that header fixups occur on ingest even outside of metadata translation.

        Attachments

          Issue Links

            Activity

            rhl Robert Lupton added a comment -

            I have a fix for some of this waiting to be pushed

            tjenness Tim Jenness added a comment -

            I've also got a fix and was about to push.

            tjenness Tim Jenness added a comment -

            I have checked this and header fixups work if both branches are used (needed a one line fix in astro_metadata_translator). In theory I can also run fix_header in assemble_raw but again the problem is that there is no mapper available so no translator class to allow you to force knowledge of the instrument onto the system.

            rhl Robert Lupton added a comment -

            Looks good.  I checked that it solved the auxTel problem that caused this.  I'll have to push the correction files of course.

             

            tjenness Tim Jenness added a comment -

            Thanks. Jenkins passed. Merged.


              People

              • Assignee:
                tjenness Tim Jenness
                Reporter:
                tjenness Tim Jenness
                Reviewers:
                Robert Lupton
                Watchers:
                Robert Lupton, Tim Jenness
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel