Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-20272

Suppress irrelevant warning when reading metadata objects

    XMLWordPrintable

    Details

    • Type: Story
    • Status: Won't Fix
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: afw
    • Labels:
      None

      Description

      When trying to access the wcs of a "raw" exposure, the following warning is issued;

      afw.image.MaskedImageFitsReader WARN: Expected extension type not found: IMAGE
      

      This warning is not relevant and can get quite verbose when looping over all CCDs of full visits. Please remove.

      How to reproduce on lsst-dev:

      import lsst.daf.persistence as dafPersist
       
      butlerDir = "/datasets/hsc/repo/rerun/RC/w_2019_22/DM-19244"
      butler = dafPersist.Butler(butlerDir)
      dataId = {"visit": 1228, "filter": "HSC-I", "ccd":49}
      rawWcs = butler.get("raw_wcs", dataId)
      

        Attachments

          Activity

          mschmitz Morgan Schmitz added a comment - - edited

          Marking as Won't Fix, since the warning is gone in gen3, eg:

          from lsst.daf.butler import Butler
           
          butler = Butler('/repo/main', collections=['HSC/runs/RC2/w_2021_22/DM-30365'])
          dataId = {"exposure": 1228, "filter": "HSC-I", "detector":49}
          butler.get("raw.wcs", dataId=dataId)
          


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            lauren Lauren MacArthur
            Watchers:
            Jim Bosch, John Parejko, Lauren MacArthur, Morgan Schmitz, Yusra AlSayyad
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Jenkins Builds

                No builds found.