Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-20288

ap_pipe --template argument broken

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Invalid
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: ap_pipe
    • Labels:

      Description

      Trying to run the following commands:

      ingest_dataset.py --dataset HiTS2015 --output repo_hits2015/ && \
      mkdir foo/ && \
      make_ppdb.py -C ${AP_VERIFY_HITS2015_DIR}/config/apPipe.py -c ppdb.isolation_level=READ_UNCOMMITTED -c ppdb.db_url="sqlite:///foo/association.db" && \
      ap_pipe.py repo_hits2015/ingested/ --calib repo_hits2015/calibingested/ --template ${AP_VERIFY_HITS2015_DIR}/templates/ --output foo -C ${AP_VERIFY_HITS2015_DIR}/config/apPipe.py -c ppdb.isolation_level=READ_UNCOMMITTED -c ppdb.db_url="sqlite:///foo/association.db" --id visit=411657 ccdnum=42..43 filter=g -j 2 --reuse-outputs-from all
      

      causes ap_pipe.py to crash with the following error:

      Traceback (most recent call last):
        File "lsstsw3/stack/Linux64/ap_pipe/17.0.1-5-g77a5af3/bin/ap_pipe.py", line 28, in <module>
          ApPipeTask.parseAndRun()
        File "lsstsw3/stack/Linux64/pipe_base/17.0.1-5-g3877d06/python/lsst/pipe/base/cmdLineTask.py", line 598, in parseAndRun
          parsedCmd = argumentParser.parse_args(config=config, args=args, log=log, override=cls.applyOverrides)
        File "lsstsw3/stack/Linux64/ap_pipe/17.0.1-5-g77a5af3/python/lsst/ap/pipe/apPipeParser.py", line 164, in parse_args
          self._makeButler(namespace)
        File "lsstsw3/stack/Linux64/ap_pipe/17.0.1-5-g77a5af3/python/lsst/ap/pipe/apPipeParser.py", line 232, in _makeButler
          namespace.butler = dafPersist.Butler(inputs=inputs, outputs=outputs)
        File "lsstsw3/stack/Linux64/daf_persistence/17.0.1-1-gfc6fb1f+10/python/lsst/daf/persistence/butler.py", line 525, in __init__
          self._setAndVerifyParentsLists(repoDataList)
        File "lsstsw3/stack/Linux64/daf_persistence/17.0.1-1-gfc6fb1f+10/python/lsst/daf/persistence/butler.py", line 890, in _setAndVerifyParentsLists
          repoData.cfg.addParents(parents)
        File "lsstsw3/stack/Linux64/daf_persistence/17.0.1-1-gfc6fb1f+10/python/lsst/daf/persistence/repositoryCfg.py", line 268, in addParents
          if newParent not in self._parents:
        File "lsstsw3/stack/Linux64/daf_persistence/17.0.1-1-gfc6fb1f+10/python/lsst/daf/persistence/repositoryCfg.py", line 97, in __eq__
          return self.root == other.root and \
      AttributeError: 'str' object has no attribute 'root'
      

      Identify the problem and make sure the command listed above works again.

      I don't think this is caused by there being two different dependency paths to the template repo (one from repo_hits2015 and one from the command line), as I originally encountered this bug with a repo that did not have the template repo as a parent.

        Attachments

          Activity

          krzys Krzysztof Findeisen added a comment -

          The HSC demo at https://github.com/lsst-dm/ap_pipe-notebooks/pull/12 did not encounter this bug; it may be worth trying to reproduce the non-occurrence.

          krzys Krzysztof Findeisen added a comment -

          ap_pipe.py was removed in DM-33254.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            krzys Krzysztof Findeisen
            Watchers:
            Krzysztof Findeisen, Meredith Rawls
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Jenkins

                No builds found.