Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-20536

Can't count on `obj_idxs` being in bounds

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: ap_association
    • Labels:
      None

      Description

      While trying to run ap_pipe with preConvolution=True, some dataIds failed on the ap_association stage. eg:

      FATAL 2019-07-11T13:02:53.312-0500 apPipe ({'visit': 1238, 'ccd': 98, 'field': 'SSP_UDEEP_COSMOS', 'dateObs': '2014-03-28', 'pointing': 817, 'filter': 'HSC-I', 'taiObs': '2014-03-28', 'expTime': 270.0})(cmdLineTask.py:397)- Failed on dataId={'visit': 1238, 'ccd': 98, 'field': 'SSP_UDEEP_COSMOS', 'dateObs': '2014-03-28', 'pointing': 817, 'filter': 'HSC-I', 'taiObs': '2014-03-28', 'expTime': 270.0}: IndexError: index 38 is out of bounds for axis 0 with size 38
      FATAL 2019-07-11T13:04:15.720-0500 apPipe ({'visit': 1246, 'ccd': 103, 'field': 'SSP_UDEEP_COSMOS', 'dateObs': '2014-03-28', 'pointing': 817, 'filter': 'HSC-I', 'taiObs': '2014-03-28', 'expTime': 270.0})(cmdLineTask.py:397)- Failed on dataId={'visit': 1246, 'ccd': 103, 'field': 'SSP_UDEEP_COSMOS', 'dateObs': '2014-03-28', 'pointing': 817, 'filter': 'HSC-I', 'taiObs': '2014-03-28', 'expTime': 270.0}: RuntimeError: No patches found!
      FATAL 2019-07-11T13:11:07.675-0500 apPipe ({'visit': 1238, 'ccd': 99, 'field': 'SSP_UDEEP_COSMOS', 'dateObs': '2014-03-28', 'pointing': 817, 'filter': 'HSC-I', 'taiObs': '2014-03-28', 'expTime': 270.0})(cmdLineTask.py:397)- Failed on dataId={'visit': 1238, 'ccd': 99, 'field': 'SSP_UDEEP_COSMOS', 'dateObs': '2014-03-28', 'pointing': 817, 'filter': 'HSC-I', 'taiObs': '2014-03-28', 'expTime': 270.0}: IndexError: index 34 is out of bounds for axis 0 with size 34
      FATAL 2019-07-11T13:18:27.189-0500 apPipe ({'visit': 1238, 'ccd': 100, 'field': 'SSP_UDEEP_COSMOS', 'dateObs': '2014-03-28', 'pointing': 817, 'filter': 'HSC-I', 'taiObs': '2014-03-28', 'expTime': 270.0})(cmdLineTask.py:397)- Failed on dataId={'visit': 1238, 'ccd': 100, 'field': 'SSP_UDEEP_COSMOS', 'dateObs': '2014-03-28', 'pointing': 817, 'filter': 'HSC-I', 'taiObs': '2014-03-28', 'expTime': 270.0}: IndexError: index 224 is out of bounds for axis 0 with size 224
      

      which is from https://github.com/lsst/ap_association/blob/master/python/lsst/ap/association/association.py#L612

      This looks like some failure mode where the distance is returned as inf for some diaSources, (despite your not having set an upper bound) which produces the expected behavior of returning a flag value = n points (in this case 4):

      (Pdb) len(dia_objects)
      4
      (Pdb) dists
      array([           inf, 3.39470366e-04, 2.87712120e-04, 3.24986976e-04,
             2.09797388e-04, 5.00443603e-04, 4.77567395e-04, 4.99864336e-04,
             1.33310026e-04, 3.58528102e-04, 1.12004350e-04, 3.54529474e-04,
                        inf, 1.81771009e-04, 4.18082426e-04, 1.33462009e-04,
             1.48876950e-04, 2.58281375e-04, 6.19140327e-04, 4.38035230e-04,
             9.45884785e-05, 2.12677353e-04, 4.38683345e-04, 6.46062325e-04,
             1.88193056e-04, 4.13965388e-04, 6.06120497e-04, 4.06044351e-04,
             5.83160070e-04, 3.95516906e-04, 2.74059920e-04, 2.21553182e-04,
             2.26415781e-04, 5.64072359e-04, 5.79131387e-04, 6.63503591e-04,
             8.34488898e-04, 4.25167947e-04, 8.32268198e-04, 4.34112545e-04,
             2.04662618e-04, 3.73198069e-04, 6.91330856e-04, 7.06692744e-04,
             8.75070394e-05, 9.04586832e-04, 1.64555013e-04, 4.46136353e-04,
             2.84480881e-04, 1.05083764e-03, 1.17729476e-03, 7.32235889e-04,
             4.84333806e-04, 6.72715508e-04, 3.60535417e-04, 5.07654976e-04,
             1.03698729e-03, 1.22701689e-03, 1.31727626e-03, 1.10645719e-03,
             9.48651990e-04, 5.26152766e-04, 5.42898829e-04, 5.53111663e-04,
             8.86445016e-04, 1.33463361e-03, 1.05134358e-03, 7.10162430e-04,
             1.31023614e-03,            inf, 1.20190626e-03, 8.42393869e-04,
             8.90818870e-04, 1.61531283e-03, 1.30757514e-03, 9.61624113e-04,
             1.10305108e-03, 1.41183753e-03, 1.67478608e-03, 1.12513779e-03,
             1.07850540e-03, 1.18741103e-03, 1.15155631e-03, 1.93253143e-03,
             1.33435522e-03, 1.88592052e-03, 1.34288681e-03,            inf,
             1.59098384e-03, 1.44037035e-03, 1.45541046e-03, 1.97276848e-03,
             1.83746994e-03, 1.98287152e-03, 2.20175350e-03, 1.89541959e-03,
             1.81040203e-03, 1.98075464e-03, 2.31995026e-03, 2.28856630e-03,
             2.30179302e-03, 2.29817933e-03, 2.37023074e-03, 2.13633563e-03,
             2.09017129e-03,            inf, 2.52452285e-03, 2.63064197e-03,
             2.50920251e-03, 2.16545745e-03, 2.61624181e-03, 2.39901930e-03,
             2.25197331e-03, 2.63819654e-03, 2.48899074e-03, 5.01476338e-04])
      (Pdb) obj_idxs
      array([4, 1, 1, 1, 1, 1, 1, 1, 0, 1, 0, 1, 4, 2, 2, 0, 0, 2, 0, 0, 2, 2,
             0, 0, 2, 0, 0, 0, 0, 3, 2, 3, 3, 0, 0, 0, 0, 3, 0, 3, 3, 3, 0, 0,
             3, 0, 3, 3, 3, 0, 0, 3, 3, 3, 3, 3, 3, 0, 0, 3, 3, 3, 3, 3, 3, 0,
             3, 3, 3, 4, 3, 3, 3, 3, 3, 3, 3, 3, 3, 3, 3, 3, 3, 3, 3, 3, 3, 4,
             3, 3, 3, 3, 3, 3, 3, 3, 3, 3, 3, 3, 3, 3, 3, 3, 3, 4, 3, 3, 3, 3,
             3, 3, 3, 3, 3, 0])
      

      I'm not sure WHY it thinks that inf is greater than inf, but regardless, I'd expect this to just return no matches.

      Can reproduce from /datasets/hsc/repo/rerun/private/yusra/RC2/ap_pipe/w_2019_26_preConv with {{
      ap_pipe.py /datasets/hsc/repo --calib /datasets/hsc/repo/CALIB/ --template /datasets/hsc/repo/rerun/private/yusra/RC2/ap_pipe_templates_noSkyCorr --rerun RC/w_2019_26/DM-19560-sfm:private/yusra/RC2/ap_pipe/w_2019_26_preConv --configfile ./configfile.py --no-versions  --longlog --id visit=19712 ccd=49 --reuse-outputs-from=all --clobber-config}}

        Attachments

          Issue Links

            Activity

            yusra Yusra AlSayyad added a comment -

            Will check look into it.

            It probably is the responsibility of the interface to the first layer with the constraint.

            Either way it's not related to this ticket, so feel free to get this reviewed and merged.

            cmorrison Chris Morrison added a comment -

            Okay, so it is would be the responsibility of association to make sure the values are safe? What I'm confused what to do with a source that has nan for ra/dec. Should I throw the object out or should I find a centroid that is valid and recompute the ra/dec for that location? This seems like a deep enough question that it should be made further up the pipeline as it likely wouldn't just affect the association step.

            cmorrison Chris Morrison added a comment -

            Created DM-20760 consultation with John Swinbank to safely handle the failures shown here. Will put this ticket into review (with Yusra AlSayyad if that's okay).

            Jenkis run: https://ci.lsst.codes/blue/organizations/jenkins/stack-os-matrix/detail/stack-os-matrix/30168/pipeline

            yusra Yusra AlSayyad added a comment -

            I can review. I'm posting this here NOT because it's necessary for this ticket but so I know where to pick up later: For the source in question, the 'ip_diffim_NaiveDipoleCentroid_flag' is False and the value is NaN. I'll look into this, but its already going to be a late night with previously scheduled work.

            butler = Butler('/datasets/hsc/repo/rerun/private/yusra/RC2/ap_pipe/w_2019_26_preConv')
            src = butler.get('deepDiff_diaSrc', dataId={'visit': 19712, 'ccd': 49})
            src[0]
            <class 'lsst.afw.table.source.source.SourceRecord'>
            id: 16932689521159371
            coord_ra: nan rad
            coord_dec: nan rad
            parent: 0
            flags_negative: 0
            base_NaiveCentroid_x: 466.96
            base_NaiveCentroid_y: 47.0269
            base_NaiveCentroid_flag: 0
            base_NaiveCentroid_flag_noCounts: 0
            base_NaiveCentroid_flag_edge: 0
            base_NaiveCentroid_flag_resetToPeak: 0
            base_PeakCentroid_x: 467
            base_PeakCentroid_y: 47
            base_PeakCentroid_flag: 0
            base_SdssCentroid_x: 467
            base_SdssCentroid_y: 47
            base_SdssCentroid_xErr: nan
            base_SdssCentroid_yErr: nan
            base_SdssCentroid_flag: 1
            base_SdssCentroid_flag_edge: 0
            base_SdssCentroid_flag_noSecondDerivative: 0
            base_SdssCentroid_flag_almostNoSecondDerivative: 0
            base_SdssCentroid_flag_notAtMaximum: 0
            base_SdssCentroid_flag_resetToPeak: 1
            ip_diffim_NaiveDipoleCentroid_flag: 0
            ip_diffim_NaiveDipoleCentroid_pos_flag: 0
            ip_diffim_NaiveDipoleCentroid_neg_flag: 0
            ip_diffim_NaiveDipoleCentroid_x: nan
            ip_diffim_NaiveDipoleCentroid_y: nan
            ip_diffim_NaiveDipoleCentroid_xErr: nan
            ip_diffim_NaiveDipoleCentroid_yErr: nan
            ip_diffim_NaiveDipoleCentroid_pos_x: nan
            ip_diffim_NaiveDipoleCentroid_pos_y: nan
            ip_diffim_NaiveDipoleCentroid_pos_xErr: nan
            ip_diffim_NaiveDipoleCentroid_pos_yErr: nan
            ip_diffim_NaiveDipoleCentroid_neg_x: nan
            ip_diffim_NaiveDipoleCentroid_neg_y: nan
            ip_diffim_NaiveDipoleCentroid_neg_xErr: nan
            ip_diffim_NaiveDipoleCentroid_neg_yErr: nan
            base_SdssShape_xx: nan
            base_SdssShape_yy: nan
            base_SdssShape_xy: nan
            base_SdssShape_xxErr: nan
            base_SdssShape_yyErr: nan
            base_SdssShape_xyErr: nan
            base_SdssShape_x: nan
            base_SdssShape_y: nan
            base_SdssShape_instFlux: nan
            base_SdssShape_instFluxErr: nan
            base_SdssShape_psf_xx: nan
            base_SdssShape_psf_yy: nan
            base_SdssShape_psf_xy: nan
            base_SdssShape_instFlux_xx_Cov: nan
            base_SdssShape_instFlux_yy_Cov: nan
            base_SdssShape_instFlux_xy_Cov: nan
            base_SdssShape_flag: 1
            base_SdssShape_flag_unweightedBad: 0
            base_SdssShape_flag_unweighted: 0
            base_SdssShape_flag_shift: 0
            base_SdssShape_flag_maxIter: 0
            base_SdssShape_flag_psf: 0
            base_CircularApertureFlux_3_0_instFlux: nan
            base_CircularApertureFlux_3_0_instFluxErr: nan
            base_CircularApertureFlux_3_0_flag: 1
            base_CircularApertureFlux_3_0_flag_apertureTruncated: 0
            base_CircularApertureFlux_3_0_flag_sincCoeffsTruncated: 0
            base_CircularApertureFlux_4_5_instFlux: nan
            base_CircularApertureFlux_4_5_instFluxErr: nan
            base_CircularApertureFlux_4_5_flag: 1
            base_CircularApertureFlux_4_5_flag_apertureTruncated: 0
            base_CircularApertureFlux_4_5_flag_sincCoeffsTruncated: 0
            base_CircularApertureFlux_6_0_instFlux: nan
            base_CircularApertureFlux_6_0_instFluxErr: nan
            base_CircularApertureFlux_6_0_flag: 1
            base_CircularApertureFlux_6_0_flag_apertureTruncated: 0
            base_CircularApertureFlux_6_0_flag_sincCoeffsTruncated: 0
            base_CircularApertureFlux_9_0_instFlux: nan
            base_CircularApertureFlux_9_0_instFluxErr: nan
            base_CircularApertureFlux_9_0_flag: 1
            base_CircularApertureFlux_9_0_flag_apertureTruncated: 0
            base_CircularApertureFlux_9_0_flag_sincCoeffsTruncated: 0
            base_CircularApertureFlux_12_0_instFlux: nan
            base_CircularApertureFlux_12_0_instFluxErr: nan
            base_CircularApertureFlux_12_0_flag: 1
            base_CircularApertureFlux_12_0_flag_apertureTruncated: 0
            base_CircularApertureFlux_17_0_instFlux: nan
            base_CircularApertureFlux_17_0_instFluxErr: nan
            base_CircularApertureFlux_17_0_flag: 1
            base_CircularApertureFlux_17_0_flag_apertureTruncated: 0
            base_CircularApertureFlux_25_0_instFlux: nan
            base_CircularApertureFlux_25_0_instFluxErr: nan
            base_CircularApertureFlux_25_0_flag: 1
            base_CircularApertureFlux_25_0_flag_apertureTruncated: 0
            base_CircularApertureFlux_35_0_instFlux: nan
            base_CircularApertureFlux_35_0_instFluxErr: nan
            base_CircularApertureFlux_35_0_flag: 1
            base_CircularApertureFlux_35_0_flag_apertureTruncated: 0
            base_CircularApertureFlux_50_0_instFlux: nan
            base_CircularApertureFlux_50_0_instFluxErr: nan
            base_CircularApertureFlux_50_0_flag: 1
            base_CircularApertureFlux_50_0_flag_apertureTruncated: 0
            base_CircularApertureFlux_70_0_instFlux: nan
            base_CircularApertureFlux_70_0_instFluxErr: nan
            base_CircularApertureFlux_70_0_flag: 1
            base_CircularApertureFlux_70_0_flag_apertureTruncated: 0
            base_GaussianFlux_instFlux: nan
            base_GaussianFlux_instFluxErr: nan
            base_GaussianFlux_flag: 1
            base_PeakLikelihoodFlux_instFlux: nan
            base_PeakLikelihoodFlux_instFluxErr: nan
            base_PeakLikelihoodFlux_flag: 1
            base_PixelFlags_flag: 1
            base_PixelFlags_flag_offimage: 0
            base_PixelFlags_flag_edge: 0
            base_PixelFlags_flag_interpolated: 0
            base_PixelFlags_flag_saturated: 0
            base_PixelFlags_flag_cr: 0
            base_PixelFlags_flag_bad: 0
            base_PixelFlags_flag_suspect: 0
            base_PixelFlags_flag_interpolatedCenter: 0
            base_PixelFlags_flag_saturatedCenter: 0
            base_PixelFlags_flag_crCenter: 0
            base_PixelFlags_flag_suspectCenter: 0
            base_PsfFlux_instFlux: nan
            base_PsfFlux_instFluxErr: nan
            base_PsfFlux_area: nan
            base_PsfFlux_flag: 1
            base_PsfFlux_flag_noGoodPixels: 0
            base_PsfFlux_flag_edge: 0
            ip_diffim_NaiveDipoleFlux_flag: 0
            ip_diffim_NaiveDipoleFlux_pos_flag: 0
            ip_diffim_NaiveDipoleFlux_neg_flag: 0
            ip_diffim_NaiveDipoleFlux_pos_instFlux: 14874.2
            ip_diffim_NaiveDipoleFlux_pos_instFluxErr: 121.96
            ip_diffim_NaiveDipoleFlux_neg_instFlux: nan
            ip_diffim_NaiveDipoleFlux_neg_instFluxErr: nan
            ip_diffim_NaiveDipoleFlux_npos: 86
            ip_diffim_NaiveDipoleFlux_nneg: 308
            ip_diffim_PsfDipoleFlux_flag: 0
            ip_diffim_PsfDipoleFlux_pos_flag: 0
            ip_diffim_PsfDipoleFlux_neg_flag: 0
            ip_diffim_PsfDipoleFlux_pos_instFlux: -604.958
            ip_diffim_PsfDipoleFlux_pos_instFluxErr: 1.41421
            ip_diffim_PsfDipoleFlux_neg_instFlux: -836.261
            ip_diffim_PsfDipoleFlux_neg_instFluxErr: 1.41421
            ip_diffim_PsfDipoleFlux_chi2dof: 6.82864
            ip_diffim_PsfDipoleFlux_pos_centroid_x: 467
            ip_diffim_PsfDipoleFlux_pos_centroid_y: 47
            ip_diffim_PsfDipoleFlux_pos_centroid_xErr: nan
            ip_diffim_PsfDipoleFlux_pos_centroid_yErr: nan
            ip_diffim_PsfDipoleFlux_neg_centroid_x: 459
            ip_diffim_PsfDipoleFlux_neg_centroid_y: 40
            ip_diffim_PsfDipoleFlux_neg_centroid_xErr: nan
            ip_diffim_PsfDipoleFlux_neg_centroid_yErr: nan
            ip_diffim_PsfDipoleFlux_centroid_x: 463
            ip_diffim_PsfDipoleFlux_centroid_y: 43.5
            ip_diffim_PsfDipoleFlux_centroid_xErr: nan
            ip_diffim_PsfDipoleFlux_centroid_yErr: nan
            ip_diffim_ClassificationDipole_value: 0
            ip_diffim_ClassificationDipole_flag: 0
            ip_diffim_DipoleFit_pos_instFlux: nan
            ip_diffim_DipoleFit_pos_instFluxErr: nan
            ip_diffim_DipoleFit_pos_centroid_x: nan
            ip_diffim_DipoleFit_pos_centroid_y: nan
            ip_diffim_DipoleFit_neg_instFlux: nan
            ip_diffim_DipoleFit_neg_instFluxErr: nan
            ip_diffim_DipoleFit_neg_centroid_x: nan
            ip_diffim_DipoleFit_neg_centroid_y: nan
            ip_diffim_DipoleFit_centroid_x: nan
            ip_diffim_DipoleFit_centroid_y: nan
            ip_diffim_DipoleFit_instFlux: nan
            ip_diffim_DipoleFit_orientation: nan
            ip_diffim_DipoleFit_separation: nan
            ip_diffim_DipoleFit_chi2dof: nan
            ip_diffim_DipoleFit_signalToNoise: nan
            ip_diffim_DipoleFit_flag_classification: 0
            ip_diffim_DipoleFit_flag_classificationAttempted: 0
            ip_diffim_DipoleFit_flag: 1
            ip_diffim_DipoleFit_flag_edge: 0
            ip_diffim_forced_PsfFlux_instFlux: nan
            ip_diffim_forced_PsfFlux_instFluxErr: nan
            ip_diffim_forced_PsfFlux_area: nan
            ip_diffim_forced_PsfFlux_flag: 1
            ip_diffim_forced_PsfFlux_flag_noGoodPixels: 0
            ip_diffim_forced_PsfFlux_flag_edge: 0
            

            cmorrison Chris Morrison added a comment -

              People

              • Assignee:
                cmorrison Chris Morrison
                Reporter:
                yusra Yusra AlSayyad
                Reviewers:
                Yusra AlSayyad
                Watchers:
                Chris Morrison, Yusra AlSayyad
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel