Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-20546

Cleanup some afw deprecations

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: afw
    • Labels:
      None
    • Story Points:
      2
    • Sprint:
      Arch 2019-07-22
    • Team:
      Architecture

      Description

      afw has some deprecated code that is not formally marked with the new @deprecated scheme. Some of these have been deprecated for many years. For deprecations over a year old, remove them. For others try to use the modern scheme.

      This ticket is not fixing the afw.geom deprecations described in DM-17566.

        Attachments

          Issue Links

            Activity

            krzys Krzysztof Findeisen added a comment -

            This is a duplicate of DM-17566. Feel free to take over that issue, though; I'm unlikely to have time for technical debt work in the near future.

            tjenness Tim Jenness added a comment -

            I don't think it's a duplicate since I'm not tackling geom at all.

            tjenness Tim Jenness added a comment -

            Kian-Tat Lim in the end I have added afwGeom deprecation to this ticket and removed some other python deprecations. I have not tackled C++ deprecations and I will leave those to DM-17566. Can you please take a look?

            ktl Kian-Tat Lim added a comment -

            The deprecations and removal of deprecated usages look reasonable. One minor suggestion for making things more concise.


              People

              • Assignee:
                tjenness Tim Jenness
                Reporter:
                tjenness Tim Jenness
                Reviewers:
                Kian-Tat Lim
                Watchers:
                Kian-Tat Lim, Krzysztof Findeisen, Tim Jenness
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: