Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-20571

Diagnose failed ap_verify build

    XMLWordPrintable

    Details

    • Type: Story
    • Status: Won't Fix
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: ap_verify
    • Labels:
      None

      Description

      scipipe/ap_verify build #286 was run using the 18.0.0 release branch rather than the master version of the Stack. For some reason, this version could not load defects ("No registry for lookup"; see attached log).

      While the error does not apply to recent Stack builds, we should determine:

      • if it was caused by a problem in, e.g., defects handling that could affect future release builds
      • if it's a sign that the 18.0.0 release build is broken in some way and needs to be patched

        Attachments

          Issue Links

            Activity

            krzys Krzysztof Findeisen added a comment -

            I think I know what the problem might be: ap_verify_ci_hits2015 does not have an 18.0.0 tag (because it's not part of lsst_distrib), so build 286 must have tried to combine a pre-DM-19857 Stack with a current dataset.

            swinbank John Swinbank added a comment -

            Ah, good catch. Yuck!

            krzys Krzysztof Findeisen added a comment -

            Assigning to John Swinbank, as it looks like the root cause is something either in our Jenkins setup or in the release process.

            swinbank John Swinbank added a comment -

            This problem should be swept up in future Jenkins updates, but we're not planning to allocate future effort to it beside that. I propose to close this as “Won't Fix” until and unless it recurs at the level that it's a real thorn in our side.


              People

              Assignee:
              swinbank John Swinbank
              Reporter:
              krzys Krzysztof Findeisen
              Watchers:
              John Swinbank, Krzysztof Findeisen
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Due:
                Created:
                Updated:
                Resolved:

                  Jenkins

                  No builds found.