Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-20573

Remove obs_lsstSim package from lsst_obs metapackage

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: obs_lsstSim
    • Labels:
      None
    • Story Points:
      1
    • Sprint:
      AP S20-5 (April)
    • Team:
      Alert Production
    • Urgent?:
      No

      Description

      The obs_lsstSim package must be removed from the lsst_obs metapackage and moved to legacy prior to the release v20.0.0

        Attachments

          Issue Links

            Activity

            Hide
            Parejkoj John Parejko added a comment -

            Package changes merged. Will do the "legacy move" next.

            Show
            Parejkoj John Parejko added a comment - Package changes merged. Will do the "legacy move" next.
            Hide
            Parejkoj John Parejko added a comment -

            Nevermind, I do not have permissions to do the "legacy move". Someone with the appropriate permissions will have to do that step.

            Show
            Parejkoj John Parejko added a comment - Nevermind, I do not have permissions to do the "legacy move". Someone with the appropriate permissions will have to do that step.
            Hide
            swinbank John Swinbank added a comment -

            Both obs_lsstSim and testdata_lsstSim moved to legacy.

            Show
            swinbank John Swinbank added a comment - Both obs_lsstSim and testdata_lsstSim moved to legacy.
            Hide
            Parejkoj John Parejko added a comment -

            Thank you. I have updated repos.yaml to point to the new location. I believe that completes this ticket.

            Show
            Parejkoj John Parejko added a comment - Thank you. I have updated repos.yaml to point to the new location. I believe that completes this ticket.
            Hide
            tjenness Tim Jenness added a comment -

            Looks like we missed lsst_ci metapackage (which means that releases won't have obs_lsstSim but all the Jenkins stack-os-matrix jobs people run will include it). I'm not entirely sure why lsst_ci lists every obs package separately but I assume it's because we only have CI for some packages, although it doesn't seem like it would hurt to use lsst_obs instead. Explicit obs packages were added all the way back in DM-5370, I think before lsst_obs existed.

            Show
            tjenness Tim Jenness added a comment - Looks like we missed lsst_ci metapackage (which means that releases won't have obs_lsstSim but all the Jenkins stack-os-matrix jobs people run will include it). I'm not entirely sure why lsst_ci lists every obs package separately but I assume it's because we only have CI for some packages, although it doesn't seem like it would hurt to use lsst_obs instead. Explicit obs packages were added all the way back in DM-5370 , I think before lsst_obs existed.

              People

              • Assignee:
                Parejkoj John Parejko
                Reporter:
                gcomoretto Gabriele Comoretto
                Reviewers:
                Tim Jenness
                Watchers:
                Gabriele Comoretto, John Parejko, John Swinbank, Scott Daniel, Simon Krughoff, Tim Jenness
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel