Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-20811

Build FFTW with --enable-openmp

    Details

    • Type: Story
    • Status: Won't Fix
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Story Points:
      1
    • Sprint:
      AP F19-2, AP F19-4 (2H September), AP F19-5 (October), AP F19-6 (November), AP S20-1 (December), AP S20-2 (January), AP S20-3 (February), AP S20-4 (March), AP S20-5 (April), AP S20-6 (May)
    • Team:
      Alert Production

      Description

      By request of Heather Kelly, try compiling FFTW with --enable-openmp.

      Note that we don't want the DM code to link against the OpenMP version; rather, we just want to make available libfftw_omp for DESC use.

        Attachments

          Activity

          Hide
          swinbank John Swinbank added a comment -

          Following the switch to having third party packages provided by Conda, this issue is no longer valid — we aren't building FFTW at all.

          Heather Kelly, does Conda's FFTW do what you need? If not, please ping me (or file a new ticket) and we'll work out what support you require.

          Show
          swinbank John Swinbank added a comment - Following the switch to having third party packages provided by Conda, this issue is no longer valid — we aren't building FFTW at all. Heather Kelly , does Conda's FFTW do what you need? If not, please ping me (or file a new ticket) and we'll work out what support you require.

            People

            • Assignee:
              swinbank John Swinbank
              Reporter:
              swinbank John Swinbank
              Watchers:
              Heather Kelly, John Swinbank
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: