Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-21426

Remove expectation that wcslib is in package provenance in ci_hsc_gen2

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: ci_hsc
    • Labels:
      None

      Description

      ci_hsc_gen2 includes a check that the package provenance recorded by the CmdLineTask machinery includes a few packages, and that list includes wcslib.  Since our own WCS classes now use AST instead, whether wcslib appears depends on whether other optional stack packages that still use wcslib are set up, and that makes this test fragile.

        Attachments

          Issue Links

            Activity

            jbosch Jim Bosch added a comment -
            jbosch Jim Bosch added a comment -

            Kian-Tat Lim, up for a quick review, since the change is trivial and you've already got the context?

            tjenness Tim Jenness added a comment -

            Looks fine to me. This was caused by DM-21407 which I merged yesterday. Sorry about that. I checked it with the default Jenkins but it didn't occur to me that ci_hsc would require that meas_astrom depended on astrometry_net which depended on wcslib.

            jbosch Jim Bosch added a comment -

            Tim Jenness, mind reviewing?  My attempt to have a day where I didn't ask you for a review apparently failed when I didn't catch K-T in the right time zone.

            tjenness Tim Jenness added a comment -

            Already approved on GitHub.


              People

              • Assignee:
                jbosch Jim Bosch
                Reporter:
                jbosch Jim Bosch
                Reviewers:
                Tim Jenness
                Watchers:
                Jim Bosch, Kian-Tat Lim, Tim Jenness
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel