Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-21444

AP pipeline algorithms in F19B

    Details

    • Type: Epic
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Epic Name:
      f19b-ap-algorithms
    • Story Points:
      55
    • WBS:
      02C.03.04
    • Team:
      Alert Production
    • Cycle:
      Fall 2019

      Description

      Algorithmic development on the alert generation pipeline and image differencing during F19B. To include deeper understanding of algorithmic issues in ip_diffim, especially focused around PIPE-34, as well as any overall changes to the AP pipeline workflow.

        Attachments

        Stories in Epic (Custom Issue Matrix)

        Key Summary Story Points Assignee Status
         
        DM-21705

        Use the correct kernelSize in case of science image convolution in image differencing

        1 Gabor Kovacs Done
         
        DM-21704

        Check whether the template scaling has a connection to the number of detected souorces

        4 Gabor Kovacs Done
         
        DM-21703

        Run the science image convolution image differencing for a visit when it is not a close matching PSF case

        4 Gabor Kovacs Done
         
        DM-21702

        Investigate the cause of the high number of false sources in convolveTemplate=False image differencing

        0 Gabor Kovacs Done
         
        DM-21811

        Write RFC about bitwise_and mask plane pixel operations and convolution that would use this

        1 Gabor Kovacs Done
         
        DM-21809

        Check the variance plane operations and the decorrelation afterburner operations in the science convolution case

        4 Gabor Kovacs Done
         
        DM-21920

        Try out and write notebook about demonstrating basic DFT space steps for ip_diffim operations

        8 Gabor Kovacs Done
         
        DM-18120

        Remove --silent command-line argument from ap_verify.py

        1 Krzysztof Findeisen Done
         
        DM-16544

        Investigate mask propagation through ip_diffim

        8 Gabor Kovacs Done
         
        DM-21700

        Photometric scaling of fluxes differ between template coadds and calexps

        1 Unassigned Won't Fix
         
        DM-19524

        Demonstrate image differencing in the DMTN-021 regime

        4 Gabor Kovacs Won't Fix
         
        DM-19523

        Demonstrate image differencing in the DMTN-006 regime

        4 Gabor Kovacs Won't Fix
         
        DM-12550

        Allow user to specify a template for ap_verify

        2 Krzysztof Findeisen Won't Fix

          Activity

          swinbank John Swinbank added a comment -

          Algorithmic development and refactoring of ip_diffim will continue on DM-22635. Upgrades to the AP QA system, etc, will take place on DM-22634.


            People

            • Assignee:
              swinbank John Swinbank
              Reporter:
              swinbank John Swinbank
              Watchers:
              John Swinbank
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Summary Panel