Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-22366

ATSpectrograph reporting invalid filter

    XMLWordPrintable

Details

    • Bug
    • Status: Done
    • Resolution: Done
    • None
    • None
    • Telescope and Site

    Description

      The ATSpectrograph is publishing a value in the changeFilter event (see attached chronograf image). 

      The filter values are defined in the configuration, but currently it's giving "disperser"

      Attachments

        Issue Links

          Activity

            tjenness Tim Jenness added a comment -

            Do we have any idea what filter really is in use when it says "disperser"?

            tjenness Tim Jenness added a comment - Do we have any idea what filter really is in use when it says "disperser"?

            Turns out this isn't a code problem. The issue is that we put a diffuser in the filter wheel, but mistakenly called it a disperser, which caused confusion.

            We use the diffuser for flats in the lab, We'll probably keep it installed for awhile once on-sky as well.

            Marking ticket as invalid.

            pingraham Patrick Ingraham added a comment - Turns out this isn't a code problem. The issue is that we put a diffuser in the filter wheel, but mistakenly called it a disperser, which caused confusion. We use the diffuser for flats in the lab, We'll probably keep it installed for awhile once on-sky as well. Marking ticket as invalid.
            tjenness Tim Jenness added a comment -

            Are you going to fix the typo though?

            tjenness Tim Jenness added a comment - Are you going to fix the typo though?

            Yes, this is on tribeiro's plate.

            pingraham Patrick Ingraham added a comment - Yes, this is on tribeiro 's plate.

            Fixing it in DM-22004

            tribeiro Tiago Ribeiro added a comment - Fixing it in DM-22004

            I changed the ticket to a Bug and marked it as done. I changed it in the default configuration in the CSC, which seemed like a more natural place to fix this than to "patch" it on the configuration repo.

            tribeiro Tiago Ribeiro added a comment - I changed the ticket to a Bug and marked it as done. I changed it in the default configuration in the CSC, which seemed like a more natural place to fix this than to "patch" it on the configuration repo.

            People

              tribeiro Tiago Ribeiro
              pingraham Patrick Ingraham
              Christopher Waters, Patrick Ingraham, Tiago Ribeiro, Tim Jenness
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Jenkins

                  No builds found.