Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-22781

Investigate spurious DIA Sources wrt good seeing selector in Dec 2019 ap_pipe rerun

    Details

    • Type: Story
    • Status: Won't Fix
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: ap_pipe
    • Labels:
      None
    • Story Points:
      4
    • Sprint:
      AP S20-3 (February)
    • Team:
      Alert Production

      Description

      In a few CCDs in one of the three HiTS fields, despite an otherwise successful rerun with new templates at a resolution of 0.26" (DM-21330 and DM-22729), there are a bunch of false positive sources that look a lot like the problems we used to have with a poorly modeled background.

      When Ian and I looked at the template nImages, all regions with data have 20 or 21 constituent visits. This suggests the good seeing selector isn't working as intended (as there are only 21 visits to choose from!). In addition, the variance plane has very low values in the regions with oodles of sources, roughly a factor of 3 lower than surrounding areas. It's unclear if these issues are related. We did a little digging and found no apparently significant codebase or default config changes in pipe_tasks or ip_diffim.

      This ticket is to figure out what happened and make a plan to fix it, which may or may not include reworking the good seeing selector so it is more readily parallelized.

        Attachments

          Issue Links

            Activity

            gkovacs Gabor Kovacs added a comment -

            I have somewhat contradictory thoughts regarding this issue at the moment.

            Without investigating the affected exposures/difference images (ccd-s) in details, I think that the spatially uniform surge in the number of detection is directly caused indeed by the lower variance plane values in the difference images. This was also the conclusion in DM-21702 (related to : DM-21017 , DM-21217). On the other hand, I think the actual background model is of a much smaller effect (source detection has its own background estimation anyway? TBC)

            The variance plane of the difference image should be (almost) identical to the variance plane of the calexp – the template noise is negligible from this aspect (it's low due to the coaddition and it gets convolved which decreases it further).

            I've briefly checked the good seeing selector BestSeeingWcsSelectImagesTask, it simply allows all images up to nImagesMax where the psf fwhm falls between the static config values of minPsfFwhm and maxPsfFwhm (in arcsec). So if all images are good, then it basically selects all of them. This behavior does not sound suspicious for me. Of course, if the number of images seem to depend on the coadd pixel resolution then there may be an issue with the psf information scaling. But I still can't see the connection to the outlier number of detections on certain ccds.

            So I think, the direction to look at is whether/why certain calexp ccds' variance are lower. Of course, there is the question, why did not we see this effect earlier?

            mrawls Meredith Rawls added a comment -

            While the specific cause of this problem is unknown, I subsequently realized I had made template coadds by selecting all of the HiTS 2014 visits rather than just a subset of them with good seeing. When I fixed this error, the problem went away. It is worth noting that Ian Sullivan found a similar issue when he made coadd templates from HiTS 2015 even when he did use a good seeing criterion.

            Marking as "won't fix" for now, with the intention to revisit the good seeing selector later in DM-23068.


              People

              • Assignee:
                mrawls Meredith Rawls
                Reporter:
                mrawls Meredith Rawls
                Watchers:
                Eric Bellm, Gabor Kovacs, Ian Sullivan, Meredith Rawls
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel