Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-22793

Strange pyvo warning about votable version

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      WARNING: W21: None:2:0: W21: vo.table is designed for VOTable version 1.1, 1.2 and 1.3, but this file is 1.4 [astropy.io.votable.tree] WARNING:astropy:W21: None:2:0: W21: vo.table is designed for VOTable version 1.1, 1.2 and 1.3, but this file is 1.4 WARNING: W41: None:2:0: W41: An XML namespace is specified, but is incorrect. Expected 'http://www.ivoa.net/xml/VOTable/v1.4', got 'http://www.ivoa.net/xml/VOTable/v1.3' [astropy.io.votable.tree] WARNING:astropy:W41: None:2:0: W41: An XML namespace is specified, but is incorrect. Expected 'http://www.ivoa.net/xml/VOTable/v1.4', got 'http://www.ivoa.net/xml/VOTable/v1.3'

       

      This happened after running the notebook in LSP int after patching qserv to point to the one running in kubernetes.  I'm not sure where this has come from.

        Attachments

          Issue Links

            Activity

            Hide
            cbanek Christine Banek added a comment -

            Okay so VOTable 1.4 is pretty new.  It is supported and known well in astropy 4.0 which is also fairly new.  When pyvo is installed in the lab containers under the default python version, astropy 4.0 is installed as a dependency.  So if you switch kernel to Python 3, this warning won't happen.

             

            If you run the LSST kernel, this pyvo installed into the stack environment uses the astropy version installed with the stack, which seems to be 3.2.3, and this doesn't know about VOTable 1.4.

            Show
            cbanek Christine Banek added a comment - Okay so VOTable 1.4 is pretty new.  It is supported and known well in astropy 4.0 which is also fairly new.  When pyvo is installed in the lab containers under the default python version, astropy 4.0 is installed as a dependency.  So if you switch kernel to Python 3, this warning won't happen.   If you run the LSST kernel, this pyvo installed into the stack environment uses the astropy version installed with the stack, which seems to be 3.2.3, and this doesn't know about VOTable 1.4.
            Hide
            cbanek Christine Banek added a comment -

            So just talked with Tim Jenness and he says we're going to be putting in an RFC for upreving to astropy 4.0 sometime soon, so that should fix this.  I'll resolve this when that happens!

            Show
            cbanek Christine Banek added a comment - So just talked with Tim Jenness and he says we're going to be putting in an RFC for upreving to astropy 4.0 sometime soon, so that should fix this.  I'll resolve this when that happens!
            Hide
            cbanek Christine Banek added a comment -

            Excellent, just verified that this is fixed and gone on the recommended weekly on stable.

            Show
            cbanek Christine Banek added a comment - Excellent, just verified that this is fixed and gone on the recommended weekly on stable.

              People

              • Assignee:
                cbanek Christine Banek
                Reporter:
                cbanek Christine Banek
                Watchers:
                Christine Banek
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel