Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-23097

Warp processing failure around field edges

    Details

    • Type: Story
    • Status: Won't Fix
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: pipe_tasks
    • Labels:
    • Team:
      External

      Description

      We encountered a few processing failures in the HSC S19A production around the edges of the field:

      RuntimeError: AST: Error at line 53 in file src/FitsChan.cc.astFindFits(FitsChan): Cannot encode floating point value nan into a FITS header card for keyword 'BGMEAN'.
      

      The problem occurs in deblendCoaddSources, and brings multibandDriver down.

      The coadd image (tract=9812 patch=5,3 filter=NB0921) is completely NAN. In this case, the only contribution to the image is visit=67792 ccd=103.

      Make this fail nicely.

        Attachments

          Activity

          price Paul Price added a comment -

          I've been unable to reproduce this failure, even when I substitute the bad coadd from S19A. I've checked that we're still putting BGMEAN = NaN, but I believe DM-21355 fixed reading/writing NANs in the header.

          tjenness Tim Jenness added a comment -

          Yes. We did fix that a while ago. I thought I recognized it.


            People

            • Assignee:
              price Paul Price
              Reporter:
              price Paul Price
              Watchers:
              Paul Price, Tim Jenness
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: