Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-23176

Update ApiVersion for the EFD Helm Charts

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      When deploying some of the EFD Helm charts to the NCSA test stand k8s cluster I've got an Deployment.extensions "" not found error because of

      apiVersion: extensions/v1beta1
      kind: Deployment
      

      The v1.16 k8s (version running at NCSA) stoped serving deprecated API versions like extensions/v1beta1 in favor of newer and more stable API versions:

      https://kubernetes.io/blog/2019/07/18/api-deprecations-in-1-16/

      For Deployment migrate to use the apps/v1 API, available since v1.9.

        Attachments

          Issue Links

            Activity

            No work has yet been logged on this issue.

              People

              • Assignee:
                afausti Angelo Fausti
                Reporter:
                afausti Angelo Fausti
                Watchers:
                Angelo Fausti
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel