I'm going to propose making this a major version bump and change the namespacing as well. As discussed for ZTF alerts here the current namespacing approach we're using causes conflicts with some of the standard Java tools. Essentially, having lsst.alert and lsst.alert.foo leads to complications in the generated Java code.
After the update diaSource, diaForcedSource, cutout, etc. will all live in the top-level lsst namespace.
Since we are not really using the namespacing (and the current schemas drop named types in both lsst.* and lsst.alert.* without much rhyme or reason) I don't think this will create any major end-user complications.