Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-2424

Create transitional duplicate of Span

    XMLWordPrintable

    Details

    • Type: Story
    • Status: Invalid
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: afw
    • Labels:
      None

      Description

      One challenge in switching from PTR(Span) to Span in Footprint is that Swig won't generate wrappers for std::vector<Span> (or any other container) if %shared_ptr(Span) is used anywhere else in the codebase.

      So, to allow both the old Footprint class and the new SpanRegion to coexist (temporily), we need to have two Span classes, one wrapped with %shared_ptr and one wrapped without it.

      Since we don't want to disrupt the old Footprint class yet, we should call the new Span something else, and make it the one that's wrapped without %shared_ptr.

      This ticket can be considered complete once we have a unit test demostrating a usable Swig-wrapped std::vector<NewSpan> while all old Footprint tests continue to pass.

        Attachments

          Issue Links

            Activity

            nlust Nate Lust added a comment -

            The work of this ticket will be done in other tickets relating to SpanSets and Footprints


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              jbosch Jim Bosch
              Watchers:
              Jim Bosch, Nate Lust
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Jenkins Builds

                  No builds found.