One issue that constantly arose was how overloaded the word "script" is in the community. It's generally considered something that's often "quick" to make and does not adhere to any strict format. It also is often used for data reduction etc. It became confusing very quickly when someone would say, "We can script that." what one was referring to.
Renaming the scriptQueue to "Queue" and scripts to "Jobs" alleviates this confusion. The Queue does so much more than run unstructured scripts. It (along with salobj) provides the basis for the job to be written, command formatting, logging, passing meta-data to promote clarity, checkpoints, and providing more elegant interruption solutions than Ctrl+C! "Jobs" can then also be better defined to differentiate between production jobs (e.g. standard visit) and one-off's (e.g. try some weird test), which will come with different requirements in terms of required testing etc.