Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-2527

CameraMapper.getEupsProductName should be pure virtual

    Details

    • Type: Story
    • Status: Won't Fix
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: obs_base
    • Labels:
      None
    • Templates:
    • Team:
      Alert Production

      Description

      CameraMapper.getEupsProductName is complicated and can run quite slowly (e.g. on lsst-dev). It makes more sense to just have subclasses override the method to return the appropriate string and not offer a usable default implementation (e.g. by making the default implementation raise NotImplementedError or by making CameraMapper an abstract base class (which is a good idea, in any case, but more work).

      Fixing this is trivial, but requires updating all obs_ packages. A less disruptive alternative is to implement this change in two steps:
      1) Deprecate the method by documenting it should be overridden and by having the default implementation print a deprecation warning. Also fix those obs_ packages we maintain.
      2) In a later release make the default implementation unusable.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                rowen Russell Owen
                Reporter:
                rowen Russell Owen
                Watchers:
                Jim Bosch, John Swinbank, Joshua Hoblitt, Kian-Tat Lim, Mario Juric, Robert Lupton, Russell Owen, Steve Pietrowicz, Tim Jenness
              • Votes:
                0 Vote for this issue
                Watchers:
                9 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel