Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-25707

ts_salkafka seems to be ignoring ackcmd topic messages

    XMLWordPrintable

    Details

    • Story Points:
      0
    • Sprint:
      TSSW Sprint - Jun 22 - Jul 6
    • Team:
      Telescope and Site
    • Urgent?:
      No

      Description

      The salkafka producers seem to not be sending out ackcmd Kafka messages when the SAL topic messages are received.

        Attachments

          Issue Links

            Activity

            No builds found.
            mareuter Michael Reuter created issue -
            rowen Russell Owen made changes -
            Field Original Value New Value
            Epic Link DM-20194 [ 326513 ]
            rowen Russell Owen made changes -
            Sprint TSSW Sprint - Jun 22 - Jul 6 [ 1028 ]
            Story Points 1
            Labels ts_salkafka
            rowen Russell Owen made changes -
            Status To Do [ 10001 ] In Progress [ 3 ]
            rowen Russell Owen added a comment - - edited

            The problem is that ts_salobj's ReadTopic adds an extra filter for "ackcmd" data, in order to weed out acknowledgements to commands issued by some other Remote. That's important for normal operation but not wanted for this situation.

            My fix was to add a new filter_ackcmd argument to salobj.ReadTopic. This defaults to True, for the old behavior, but ts_salkafka overrides it. I added a unit test whose doc string includes this ticket number.

            Pull request: https://github.com/lsst-ts/ts_salkafka/pull/14

            Note that this change requires ts_salobj 6 – which requires ts_sal 4.2. So using the fix awaits release of ts_sal 4.2. If that gets badly delayed I can release a new version of ts_salobj 5 that cherry-picks the necessary change.

            rowen Russell Owen made changes -
            Story Points 1 0
            rowen Russell Owen made changes -
            Reviewers Michael Reuter [ mareuter ]
            Status In Progress [ 3 ] In Review [ 10004 ]
            rowen Russell Owen made changes -
            Link This issue relates to DM-25719 [ DM-25719 ]
            mareuter Michael Reuter added a comment -

            PR reviewed.

            mareuter Michael Reuter made changes -
            Status In Review [ 10004 ] Reviewed [ 10101 ]
            rowen Russell Owen made changes -
            Resolution Done [ 10000 ]
            Status Reviewed [ 10101 ] Done [ 10002 ]
            rowen Russell Owen added a comment -

            Released as v1.3.0


              People

              Assignee:
              rowen Russell Owen
              Reporter:
              mareuter Michael Reuter
              Reviewers:
              Michael Reuter
              Watchers:
              Michael Reuter, Russell Owen
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Jenkins

                  No builds found.