Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-25903

CALIB_ID written by findDefects.py is wrong

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: cp_pipe
    • Labels:
      None

      Description

      Sort out ambiguity between the "slot name" which is the butler-queired detectorName, i.e. just S12, and the fully qualified name reported by detector.getName().

        Attachments

          Activity

          cslage Craig Lage added a comment -

          I pulled the tickets/DM-25903 branch of cp_pipe, then created the defects with find_defects.py and ingested them with ingestCuratedCalibs.py.  The butler was now able to access the data with either:
          test = butler.get('defects', dataId={'detector': 94, 'raftName':'R22', 'expId': 3019101200480})
          or:
          test = butler.get('defects', dataId={'detector': 94, 'raftName':'R22', 'detectorName':'S11', 'expId': 3019101200480})
          which had failed before, so it looks like the problem is fixed.  I then ran the measurePhotonTransferCurve task with isr.doDefect=True, and it ran successfully with the w_2020_27 setup.  This was the original problem, so it is definitely fixed.  The measurePhotonTransferCurve task does not run with the w_2020_28 setup, but this is because the measurePhotonTransferCurve task has been refactored, and I have some fixes to do.  I think this is done.  Thanks, Merlin.


            People

            • Assignee:
              mfisherlevine Merlin Fisher-Levine
              Reporter:
              mfisherlevine Merlin Fisher-Levine
              Reviewers:
              Tim Jenness
              Watchers:
              Craig Lage, Merlin Fisher-Levine, Tim Jenness
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Summary Panel