Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-2601

'eups distrib install flask -t qserv' fails on Ubuntu 14.04

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Won't Fix
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: Qserv
    • Labels:
      None
    • Story Points:
      5
    • Sprint:
      DB_S15_04, DB_S15_05, DB_S15_06
    • Team:
      Data Access and Database

      Description

      Qserv now depends on Flask, so this blocks all Qserv install which rely on eups.

      Comman below works with system-python but not with anaconda:

      qserv@clrinfoport09:~/stack/EupsBuildDir/Linux64/flask-0.10.1/flask-0.10.1⟫ python setup.py install --home /home/qserv/stack/Linux64/flask/0.10.1                                                                  
      running install
      Traceback (most recent call last):
        File "setup.py", line 110, in <module>
          test_suite='flask.testsuite.suite'
        File "/home/qserv/stack/Linux64/anaconda/master-g68783b1848/lib/python2.7/distutils/core.py", line 151, in setup
          dist.run_commands()
        File "/home/qserv/stack/Linux64/anaconda/master-g68783b1848/lib/python2.7/distutils/dist.py", line 953, in run_commands
          self.run_command(cmd)
        File "/home/qserv/stack/Linux64/anaconda/master-g68783b1848/lib/python2.7/distutils/dist.py", line 972, in run_command
          cmd_obj.run()
        File "/usr/lib/python2.7/dist-packages/setuptools/command/install.py", line 73, in run
          self.do_egg_install()
        File "/usr/lib/python2.7/dist-packages/setuptools/command/install.py", line 82, in do_egg_install
          cmd.ensure_finalized()  # finalize before bdist_egg munges install cmd
        File "/home/qserv/stack/Linux64/anaconda/master-g68783b1848/lib/python2.7/distutils/cmd.py", line 109, in ensure_finalized
          self.finalize_options()
        File "/usr/lib/python2.7/dist-packages/setuptools/command/easy_install.py", line 274, in finalize_options
          ('install_dir','install_dir')
        File "/home/qserv/stack/Linux64/anaconda/master-g68783b1848/lib/python2.7/distutils/cmd.py", line 298, in set_undefined_options
          src_cmd_obj.ensure_finalized()
        File "/home/qserv/stack/Linux64/anaconda/master-g68783b1848/lib/python2.7/distutils/cmd.py", line 109, in ensure_finalized
          self.finalize_options()
        File "/usr/lib/python2.7/dist-packages/setuptools/command/install_lib.py", line 13, in finalize_options
          self.set_undefined_options('install',('install_layout','install_layout'))
        File "/home/qserv/stack/Linux64/anaconda/master-g68783b1848/lib/python2.7/distutils/cmd.py", line 302, in set_undefined_options
          getattr(src_cmd_obj, src_option))
        File "/home/qserv/stack/Linux64/anaconda/master-g68783b1848/lib/python2.7/distutils/cmd.py", line 105, in __getattr__
          raise AttributeError, attr
      AttributeError: install_layout

        Attachments

          Issue Links

            Activity

            jammes Fabrice Jammes added a comment -

            I can have a look at this one, but I'm not able to work on it till monday. I don't mind if somebody else want to have a look and do it quicker.

            jbecla Jacek Becla added a comment -

            Let's just package flask and it dependencies, see DM-2605

            jammes Fabrice Jammes added a comment -

            The fix is

            root@clrinfoport09:~# /usr/bin/easy_install --version
            setuptools 3.3
            qserv@clrinfoport09:~⟫ pip install -U setuptools
            qserv@clrinfoport09:~⟫ easy_install --version
            setuptools 15.1

            So the problem isn't with anaconda but with Ubuntu setuptools version.

            DM-2605 will not solve this.

            jammes Fabrice Jammes added a comment - - edited

            FYI on SL7 (flask install works here):

            fjammes@ccosvms0070:~$ easy_install --version
            setuptools 5.8


              People

              Assignee:
              jammes Fabrice Jammes
              Reporter:
              jammes Fabrice Jammes
              Watchers:
              Andy Salnikov, Brian Van Klaveren, Fabrice Jammes, Jacek Becla, Kian-Tat Lim, Mario Juric
              Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  CI Builds

                  No builds found.