In recent discussions it was suggested that something like "band", "waveband" (or "energyband" – following CAOM formalism, although that is "optical" vs "radio") could be less confusing than "abstract filter". It was clear that people weren't entirely sure what "abstract" means and we get some people thinking it means a generic filter name such as "all red filters are called r" and others who think it's nothing more than a label (so "r" and "r2" and "r3" are all abstract). Gen3 is trying to use abstract filter to mean "you can probably co-add these and get a useful answer that you expect".
Consider also renaming physical_filter to just filter if we have band. Physical filter always refers to a specific piece of hardware.
If we wish to make this change to registry and butler then we should change it before we declare schema stability.
This ticket can be marked invalid if we decide against it but I need a placeholder.