Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-27095

Ensure documenteer 0.6 works without doxygen

    XMLWordPrintable

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: documenteer
    • Labels:
      None

      Description

      To ensure backwards compatibility during the documenteer 0.6 transition, ensure that the original build-stack-docs CLI can continue to build pipelines.lsst.io without the Doxygen subsite.

        Attachments

          Issue Links

            Activity

            Hide
            jsick Jonathan Sick added a comment -

            Released as Documenteer 0.6.2:

            • The build-stack-docs CLI (replaced by stack-docs build) now defaults to not generating a Doxygen configuration, or running Doxygen.
              This is consistent with the original behaviour of build-stack-docs, which did not perform a Doxygen build.
            • The autocppapi directive now works even if the corresponding Doxylink symbol map is unavailable.
              This feature is useful for any circumstance when a Doxygen subsite that is normally present is unavailable, such as for a single-package documentation build.
            • The Doxygen subsite is only added to html_extras_path if the _doxygen/html directory is present.
            • Remove the matplotlib plot extension from the legacy documenteer.sphinxconf configuration because the extension appears to be incompatible with Sphinx 3.x.
            Show
            jsick Jonathan Sick added a comment - Released as Documenteer 0.6.2: The build-stack-docs CLI (replaced by stack-docs build) now defaults to not generating a Doxygen configuration, or running Doxygen. This is consistent with the original behaviour of build-stack-docs, which did not perform a Doxygen build. The autocppapi directive now works even if the corresponding Doxylink symbol map is unavailable. This feature is useful for any circumstance when a Doxygen subsite that is normally present is unavailable, such as for a single-package documentation build. The Doxygen subsite is only added to html_extras_path if the _doxygen/html directory is present. Remove the matplotlib plot extension from the legacy documenteer.sphinxconf configuration because the extension appears to be incompatible with Sphinx 3.x.
            Hide
            jsick Jonathan Sick added a comment -

            Released Documenteer 0.6.2 on conda-forge as well.

            Show
            jsick Jonathan Sick added a comment - Released Documenteer 0.6.2 on conda-forge as well.

              People

              Assignee:
              jsick Jonathan Sick
              Reporter:
              jsick Jonathan Sick
              Watchers:
              Jonathan Sick
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  CI Builds

                  No builds found.