Merging is blocked until I release ts_salobj 6.1 and some associated packages (including ts_hexrotcomm, ts_hexapod and ts_rotator). See
DM-27601 for details.
I renamed ts_hexapod to ts_mthexapod and ts_rotator to ts_mtrotator. tribeiro requested use of lowercase and I prefer it myself, though it does make the names look a bit strange. I have not yet renamed the repositories, because I need to finish
DM-27601 first. But I have renamed the namespaces, e.g. lsst.ts.hexapod is now lsst.ts.mthexapod, and the conda packages, e.g. ts-hexapod is now ts-mthexapod.
At this point
DM-27601 is merged so I just renamed the github repos to match.
To avoid confusion between the MTHexapod and MTRotator ts_idl enum modules and the CSC package names I modified ts_hexrotcomm, ts_hexapod, and ts_rotator to import the enum classes from these modules, e.g. from lsst.ts.idl.enums.MTHexapod import ControllerState. This change turned out to be unnecessary. Originally I thought I was going to rename the packages and namespaces with CamelCase, e.g. ts_MTHexapod, and that would have made this change far more important. I still think this change is an improvement, but am not entirely happy with it. Feel free to push back. It would be easy to undo.