Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-2749

Add instructions on how to upgrade eups in a stack

    Details

    • Type: Improvement
    • Status: Won't Fix
    • Priority: Major
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: eups
    • Labels:
      None

      Description

      As long as eups is a component of our packaging and distribution system, we need to provide instructions on how to upgrade it in an existing stack installation (and we should suggest that users upgrade to 1.5.9, particularly if they have a shared stack installation).

      Note that the vast majority of stacks do not have eups managing eups, which has been suggested at times. I think that having eups manage eups is more complex than is necessary for most people who will only upgrade occasionally.

      I believe the process amounts to mostly "move your existing one aside, make sure you're using the right Python, download/clone, configure, make install", but there may be some subtleties that we should make sure we are getting right.

      Jim Bosch and Robert Lupton seem like the obvious sources of information here.

        Attachments

          Container Issues

            Activity

              People

              • Assignee:
                frossie Frossie Economou
                Reporter:
                ktl Kian-Tat Lim
                Watchers:
                Jim Bosch, Joshua Hoblitt, Kian-Tat Lim, Robert Lupton
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel