Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-2792 Make the new astrometry task the default task
  3. DM-2793

Improve behavior of new matcher on highly distorted fields

    XMLWordPrintable

    Details

    • Type: Technical task
    • Status: Won't Fix
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: meas_astrom
    • Labels:
      None
    • Story Points:
      8
    • Sprint:
      Science Pipelines DM-W16-1
    • Team:
      Alert Production

      Description

      The optimistic matcher used by the new astrometry task probably does not handle highly distorted fields well. The issue is that it tries to match in X-Y space, and if that has significant curvature then the match is not optimal.

      I suggest matching in RA/Dec space, as per Tabur's original algorithm (on which this code is based). This is simple and easy to understand

      An alternative is to use the old technique of "undistorting" source and reference object positions before matching. This works, but is complicated, difficult to understand and adds an unnecessary step.

        Attachments

          Issue Links

            Activity

            rowen Russell Owen added a comment -

            Fixed using DM-3492


              People

              Assignee:
              rowen Russell Owen
              Reporter:
              rowen Russell Owen
              Watchers:
              Russell Owen
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Jenkins Builds

                  No builds found.