Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-29569

PTC maxMeanSignal no longer works

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: cp_pipe
    • Labels:
      None

      Description

      With the split-up of the PTC task, I think the maxMeanSignal code no longer works.  In the attached, I have verified that it takes the 50000 value, but points larger than the maxMeandSignal are still included in the fit.  I have not pinned down exactly where the information is being lost.  The plots show that the points >50000 are still being included.

      Running: /software/lsstsw/stack_20210211/stack/miniconda3-py38_4.9.2-0.4.1/Linux64/cp_pipe/21.0.0-12-gf4ce030+76814010d2/bin/measurePhotonTransferCurve.py /project/shared/comCam/rerun/cslage/PTC_2021-04-02 --rerun /project/shared/comCam/rerun/cslage/PTC_2021-04-02 --id detector=1 expId=2021040200025^2021040200026^2021040200027^2021040200028^2021040200029^2021040200030^2021040200031^2021040200032^2021040200033^2021040200034^2021040200035^2021040200036^2021040200037^2021040200038^2021040200039^2021040200040^2021040200041^2021040200042^2021040200043^2021040200044^2021040200045^2021040200046^2021040200047^2021040200048^2021040200049^2021040200050 -c solve.ptcFitType=EXPAPPROXIMATION solve.sigmaCutPtcOutliers=20.0 extract.maxMeanSignal={'ALL_AMPS':50000.0} doPhotodiode=False --clobber-config --clobber-versions -j 1

        Attachments

        1. PTC_det1_DM-29569-EXPAPPROX.pdf
          80 kB
        2. PTC_det1.pdf
          79 kB
        3. screenshot-1.png
          screenshot-1.png
          1.06 MB

          Activity

          plazas Andrés Alejandro Plazas Malagón added a comment - - edited

          1. If the mean of the difference image at a given time is outside of the flux cut specified (e.g., with maxMeanSignal, the flux point is masked as `False` for that particular amp. This is done in cpExtract}. However, in cpSolve, this information was not being read.
          2. In addition to one, the existing mask due to the above cut was being overwritten, instead of being logically combined with AND.

          Gen2 commands:

           measurePhotonTransferCurve.py /project/shared/comCam/rerun/cslage/PTC_2021-04-02 --rerun /project/shared/comCam/rerun/plazas-DM-29569/PTC_2021-04-02 --id detector=1 expId=2021040200025^2021040200026^2021040200027^2021040200028^2021040200029^2021040200030^2021040200031^2021040200032^2021040200033^2021040200034^2021040200035^2021040200036^2021040200037^2021040200038^2021040200039^2021040200040^2021040200041^2021040200042^2021040200043^2021040200044^2021040200045^2021040200046^2021040200047^2021040200048^2021040200049^2021040200050 -c solve.ptcFitType=EXPAPPROXIMATION solve.sigmaCutPtcOutliers=20.0 doPhotodiode=False -C temp.config --clobber-config --clobber-versions -j 1
          

          where temp.config is of teh form

          config.extract.maxMeanSignal={'ALL_AMPS':50000.0}
          

          plotPhotonTransferCurveGen2.py /project/shared/comCam/rerun/cslage/PTC_2021-04-02 --rerun /project/shared/comCam/rerun/plazas-DM-29569/PTC_2021-04-02 --id detector=1 -c datasetFileName=/project/shared/comCam/rerun/plazas-DM-29569/PTC_2021-04-02/calibrations/ptc/ptcDataset-det001.fits --clobber-versions --clobber-config -j 1
          

          Plot: (from PTC_det1_DM-29569-EXPAPPROX.pdf )

          czw Christopher Waters added a comment -

          Just a couple minor double-check questions on the PR.

          cslage Craig Lage added a comment -

          I pulled down the tickets/DM-29569 branch of cp_pipe and verified that the problem is fixed.  This enabled me to verify the PTC curve on the two missing channels on the ComCam.  Thanks Andrés!.


            People

            Assignee:
            plazas Andrés Alejandro Plazas Malagón
            Reporter:
            cslage Craig Lage
            Reviewers:
            Christopher Waters
            Watchers:
            Andrés Alejandro Plazas Malagón, Christopher Waters, Craig Lage
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: