Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-29856

Switch ap_verify.py to Gen 3 by default

    XMLWordPrintable

Details

    • Story
    • Status: Done
    • Resolution: Done
    • None
    • ap_verify
    • None

    Description

      Modify ap_verify.py and ingest_dataset.py to default to --gen3 when no generation argument is provided. If possible, emit a deprecation warning when --gen2 is used.

      This change does not require an RFC, as all Gen 2 support is already deprecated as of release 22.0, and I've already recommended the use of explicit generation arguments since release 21.0.

      Attachments

        Issue Links

          Activity

            Note that we cannot remove support for Gen 2 datasets until DM-29857 is resolved, which is currently blocked by DM-29543.

            krzys Krzysztof Findeisen added a comment - Note that we cannot remove support for Gen 2 datasets until DM-29857 is resolved, which is currently blocked by DM-29543 .

            People

              krzys Krzysztof Findeisen
              krzys Krzysztof Findeisen
              Ian Sullivan
              Eric Bellm, Ian Sullivan, Krzysztof Findeisen
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Jenkins

                  No builds found.