Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-30073

Fix Portal retrieval of async queries

    XMLWordPrintable

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: SUIT

      Description

      On data-int after deploying SUIT 2.2.0, Portal retrieval of async queries from TAP started failing with the error message "Failed to retrieve data"

        Attachments

          Activity

          rra Russ Allbery added a comment -

          We discovered my patch was not entirely correct, but we have come up with a new patch which is on a hotfix branch, and that appears to work correctly. This will be deployed at data-dev and data-int, and then will be rolled out once a formal release is made next week.

          rra Russ Allbery added a comment -

          The new point release has been deployed on all IDF environments. We were unable to reproduce some other instability problems we saw with TAP and are hoping that was an infrastructure problem. Next step is a real release and then to deploy that everywhere.

          gpdf Gregory Dubois-Felsmann added a comment -

          Revised fix is in Firefly release-2021.2.3, used in Portal/suit v2.3.3, test deployments likely tomorrow. Tested against RSP and against unauthenticated (e.g., IRSA, CADC) TAP services.

          rra Russ Allbery added a comment -

          The debug build of the new release is now deployed at all of the IDF environments. Remaining work on this ticket is to update the charts and phalanx configuration for the final release when that's available.

          rra Russ Allbery added a comment -

          I'm going to track the deployment of the new Portal release in a separate story since it will be a while. The fixed development version is now deployed in both the IDF and NCSA, so closing this out.


            People

            Assignee:
            rra Russ Allbery
            Reporter:
            rra Russ Allbery
            Reviewers:
            Gregory Dubois-Felsmann
            Watchers:
            Gregory Dubois-Felsmann, Loi Ly, Russ Allbery
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Jenkins Builds

                No builds found.