Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-30900

Stop using obs_* configurations in fgcmcal

    XMLWordPrintable

Details

    • Story
    • Status: Done
    • Resolution: Done
    • None
    • fgcmcal
    • None

    Description

      This is one of the implementation tickets for RFC-775; see that and https://confluence.lsstcorp.org/display/~jbosch/Reorganizing+Top-Level+Packages+and+Pipelines for more details.

      Remove any obs_* package configs usage in fgcmcal by copying those config files into fgcmcal itself, freezing them and insulating fgcmcal tests from downstream changes that reorganize those configs or customize them for specific pipelines.

      After this ticket, fgcmcal should continue to use obs_* packages only to interpret its test data repositories.

      This ticket may be a no-op; I am creating it just because I know fgcmcal depends on at least obs_* already, and I don't know what it does with that dependency.

      Attachments

        Issue Links

          Activity

            erykoff Eli Rykoff added a comment -

            I've made the changes here: https://github.com/lsst/fgcmcal/pull/65 and confirmed that the tests now run whether the fgcm config files are present in obs_subaru/config or not (by hand), and removed all explicit dependencies on the obs_subaru config files.
            However, the tests (both gen2 and gen3) will still pick up the obs_subaru/config/fgcm* files, so if these are altered with new overrides it could still affect the tests. I think that this is just temporary, and when the config files move out of obs_subaru with RFC-775 then this won't be able to happen. And the changes on this ticket will allow the fgcmcal tests to work just the same when those config files disappear, which I think is the point.

            erykoff Eli Rykoff added a comment - I've made the changes here: https://github.com/lsst/fgcmcal/pull/65 and confirmed that the tests now run whether the fgcm config files are present in obs_subaru/config or not (by hand), and removed all explicit dependencies on the obs_subaru config files. However, the tests (both gen2 and gen3) will still pick up the obs_subaru/config/fgcm* files, so if these are altered with new overrides it could still affect the tests. I think that this is just temporary, and when the config files move out of obs_subaru with RFC-775 then this won't be able to happen. And the changes on this ticket will allow the fgcmcal tests to work just the same when those config files disappear, which I think is the point.

            Can you clarify your second paragraph?  Is this just an artifact of having too many places to specify configurations, and the current default of specifying them in obs_{camera}/config/{_DefaultName}.py?

            czw Christopher Waters added a comment - Can you clarify your second paragraph?  Is this just an artifact of having too many places to specify configurations, and the current default of specifying them in obs_{camera}/config/{_DefaultName}.py?
            erykoff Eli Rykoff added a comment -

            The issue is that the task config file from {{obs_

            {camera}

            /config/{_DefaultName}.py}} will automatically be pulled in as the basis for the task config. And I'm not sure how to stop this, or even if it's necessary since the task configs will be moving out of the obs packages anyway.

            erykoff Eli Rykoff added a comment - The issue is that the task config file from {{obs_ {camera} /config/{_DefaultName}.py}} will automatically be pulled in as the basis for the task config. And I'm not sure how to stop this, or even if it's necessary since the task configs will be moving out of the obs packages anyway.

            That makes sense.  I didn't find any explicit includes, so I thought it was probably the automatic one. 

            czw Christopher Waters added a comment - That makes sense.  I didn't find any explicit includes, so I thought it was probably the automatic one. 

            People

              erykoff Eli Rykoff
              jbosch Jim Bosch
              Christopher Waters
              Christopher Waters, Eli Rykoff, Jim Bosch, Nate Lust
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Jenkins

                  No builds found.