Nate – thanks for the review! A brief response:
rename baseName to base, to be more consistent with how slots and such a documented in other places
On reflection, I agree that using "baseName" is a poor choice. However, I also don't like "base" – it's normally used to indicate the output of a measurement plugin defined in meas_base (cf the prefix "ext" for meas_extensions_*). Instead, I will change it to use "afw_Test", since this is a test in the afw package.
consider using python .format() for your string formatting. It will help future proof things, and be a bit easier to read.
You may consider it considered!
For what it's worth, I find it hard to get really excited one way or the other. When this was discussed on HipChat a few months ago (in the Tavern, so carrying no formal weight), there was no real consensus about which was the better approach; while a couple of folks are strongly in favour of one approach or the other (no prizes for guessing names), I think the general attitude was that we expect both to be supported in Python for the long term and that which is more readable depends chiefly on context.
Here, % formatting is used extensively in the other afw tests, while I don't think any of them call str.format(); for consistency, I think we should stick with the former.