Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-31659

Logging loses part of message in assembly.py

    XMLWordPrintable

    Details

    • Type: Story
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: obs_lsst
    • Labels:
      None
    • Story Points:
      0.25
    • Team:
      Architecture
    • Urgent?:
      No

      Description

      In assembly.py(128)fixAmpGeometry() the line

      logCmd("outAmp.getRawBBox() != data.getBBox(); patching. (%s v. %s)", outAmp.getRawBBox(), bbox)
       

      prints

      (minimum=(0, 0), maximum=(543, 2047)): (minimum=(0, 0), maximum=(575, 2047))
      

      I think that the problem is in the warn_once context manager, whose logging calls should look like logger.debug(s, *args) not logger.debug("%s: %s", *args)

      I'm not sure if this is a cut-and-paste error which also appears elsewhere.

        Attachments

          Activity

          tjenness Tim Jenness added a comment -

          I have no idea how this got through. Taking a look.

          tjenness Tim Jenness added a comment -

          Trivial fix. I will start a jenkins run


            People

            Assignee:
            tjenness Tim Jenness
            Reporter:
            rhl Robert Lupton
            Reviewers:
            Robert Lupton
            Watchers:
            Robert Lupton, Tim Jenness
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Jenkins Builds

                No builds found.