Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-31675

Running ellipKPM test_te1 yields different result on Princeton hosts

    XMLWordPrintable

Details

    • Story
    • Status: Won't Fix
    • Resolution: Done
    • None
    • faro
    • None
    • DM Science
    • No

    Description

      Copied from Lee's comment on related ticket:
      Testing this on the tiger machine here at Princeton, I get the following values:

      result.measurement = 9.55842919753633e-05
      expected = 9.517637187446586e-05

      With such a large gap, I'm not sure that anything like assertAlmostEqual will ever be appropriate here, and perhaps we'll need to consider something else to allow this test to pass?

      Attachments

        Issue Links

          Activity

            wittgen Matthias Wittgen added a comment - - edited

            Running a freshly installed Springdale Linux in a VM and testing with a freshly installed binary release of lsst_distrib (w_2021_36) does not reproduce the problem. Would be interesting to investigate what's the different run-time setup on tiger causing this.

            wittgen Matthias Wittgen added a comment - - edited Running a freshly installed Springdale Linux in a VM and testing with a freshly installed binary release of lsst_distrib (w_2021_36) does not reproduce the problem. Would be interesting to investigate what's the different run-time setup on tiger causing this.
            lskelvin Lee Kelvin added a comment -

            If there are any particular run-time checks I can perform, or details of installed software that might be useful here, I'd be happy to provide. Please do let me know.

            lskelvin Lee Kelvin added a comment - If there are any particular run-time checks I can perform, or details of installed software that might be useful here, I'd be happy to provide. Please do let me know.
            wittgen Matthias Wittgen added a comment - - edited

            Duplicate of DM-31611

            wittgen Matthias Wittgen added a comment - - edited Duplicate of DM-31611

            People

              Unassigned Unassigned
              wittgen Matthias Wittgen
              Colin Slater, John Parejko, Krzysztof Findeisen, Lee Kelvin, Matthias Wittgen, Tim Jenness
              Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Jenkins

                  No builds found.