Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-3183

CalibrateTask instantiates some subtasks with the wrong schema

    Details

    • Type: Bug
    • Status: Invalid
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: pipe_tasks
    • Labels:
      None
    • Story Points:
      1
    • Sprint:
      Science Pipelines DM-S15-5, Science Pipelines DM-S15-6, Science Pipelines DM-W16-1, Science Pipelines DM-W16-2
    • Team:
      Alert Production

      Description

      CalibrateTask instantiates some subtasks with the wrong schema, in particular:

      • astrometry is instantiated with the final schema but run on schema1
      • measureApCorr, applyApCorr and photocal are instantiated with schema1 but run on the final schema

      One way this can cause problems is that schema1 may not have the data needed to measure aperture correction (e.g. it may contain only one tiny radius of aperture flux), as came to light when running the lsst stack demo.

        Attachments

          Issue Links

            Activity

            rowen Russell Owen added a comment -

            Do you have time to look at this, Paul? It is a few-line change to calibrate.py in pipe_tasks on tickets/DM-3183. obs_sdss's SdssCalibrateTask already got a similar change, because instantiating measureApCorr was required to make the integration test run. Some of the other changes are probably not strictly necessary, but it seemed safer to me to always instantiate all subtasks with the schema they use (or if one task uses two schemas, then pick schema1, since it should be a subset of the final schema).

            price Paul Price added a comment -

            What's the relation of this to DM-3174?

            rowen Russell Owen added a comment - - edited

            It ended up being a duplicate of DM-3174. I will mark it as "won't fix".

            jbosch Jim Bosch added a comment -

            I believe we're supposed to be using "Invalid" rather than "Won't Fix" for duplicates, now.


              People

              • Assignee:
                rowen Russell Owen
                Reporter:
                rowen Russell Owen
                Reviewers:
                Paul Price
                Watchers:
                Jim Bosch, Paul Price, Russell Owen
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel