Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-31972

meas_extensions_piff testPsfDeterminer dies with piff 1.1.0

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Invalid
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: meas_extensions_piff
    • Labels:
      None
    • Team:
      Data Release Production
    • Urgent?:
      No

      Description

      piff was updated to 1.1.0 on 2021-09-29. This caused the testPsfDeterminer test in meas_extensions_piff to fail.

      The test gives:

      ValueError: array must not contain infs or NaNs
      

      But it appears that this stems from an underlying numpy problem:

      E           numpy.linalg.LinAlgError: Matrix is singular.
      

      which is called from within self.psfDeterminer.determinePsf.

        Attachments

          Issue Links

            Activity

            Hide
            ktl Kian-Tat Lim added a comment -

            If a quick fix cannot be implemented, we can pin rubin-env 0.7.0 to piff < 1.1.0.

            Show
            ktl Kian-Tat Lim added a comment - If a quick fix cannot be implemented, we can pin rubin-env 0.7.0 to piff < 1.1.0 .
            Hide
            yusra Yusra AlSayyad added a comment -

            Removing the blocks v23 and adding a blocks v24.

            Show
            yusra Yusra AlSayyad added a comment - Removing the blocks v23 and adding a blocks v24.
            Hide
            yusra Yusra AlSayyad added a comment -

            Though, looks like its not pinned either. Is this still a problem? https://github.com/conda-forge/rubinenv-feedstock/blob/master/recipe/meta.yaml

            Show
            yusra Yusra AlSayyad added a comment - Though, looks like its not pinned either. Is this still a problem? https://github.com/conda-forge/rubinenv-feedstock/blob/master/recipe/meta.yaml
            Hide
            ktl Kian-Tat Lim added a comment -

            My understanding is that piff 1.1.0 was marked broken at conda-forge, and that piff 1.2.0 is not being picked up because it requires galsim 2.3 which we don't yet allow, although we will at the next major rubin-env release.

            Show
            ktl Kian-Tat Lim added a comment - My understanding is that piff 1.1.0 was marked broken at conda-forge, and that piff 1.2.0 is not being picked up because it requires galsim 2.3 which we don't yet allow, although we will at the next major rubin-env release.
            Hide
            wittgen Matthias Wittgen added a comment -

            Release v24 uses galsim 2.3. Can this ticket be marked done?

            Show
            wittgen Matthias Wittgen added a comment - Release v24 uses galsim 2.3 . Can this ticket be marked done?

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              ktl Kian-Tat Lim
              Watchers:
              Kian-Tat Lim, Matthias Wittgen, Yusra AlSayyad
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Jenkins

                  No builds found.