Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-3439

Rename ingest.py to reduce confusion with database

    Details

    • Story Points:
      2

      Description

      The ingestImages.py bin script provides a camera-agnostic manner of creating a data repository (including a registry). The back-end code resides in pipe_tasks under the name ingest.py, and the IngestTask._DefaultName = "ingest", which means that configuration files in obs packages are also named ingest.py. This choice of name was unfortunate, as it may be confused with ingest of sources into the database. We should change the name to reduce this confusion, perhaps ingestImages.py like the bin script.

        Attachments

          Issue Links

            Activity

            Hide
            price Paul Price added a comment - - edited

            Suppose I should RFC this... RFC-83.

            Show
            price Paul Price added a comment - - edited Suppose I should RFC this... RFC-83 .
            Hide
            tjenness Tim Jenness added a comment -

            Paul Price are we ever going to do this or should we abandon RFC-83?

            Show
            tjenness Tim Jenness added a comment - Paul Price are we ever going to do this or should we abandon RFC-83 ?
            Hide
            price Paul Price added a comment -

            Jim Bosch, does this still make sense in the context of Gen3?

            Show
            price Paul Price added a comment - Jim Bosch , does this still make sense in the context of Gen3?
            Hide
            jbosch Jim Bosch added a comment -

            Gen3 already calls its version "RawIngestTask", which I think is probably sufficient to avoid confusion.

            Show
            jbosch Jim Bosch added a comment - Gen3 already calls its version "RawIngestTask", which I think is probably sufficient to avoid confusion.
            Hide
            price Paul Price added a comment -

            So can we abandon this, and simply let the confusion die with Gen2?

            Show
            price Paul Price added a comment - So can we abandon this, and simply let the confusion die with Gen2?

              People

              • Assignee:
                Unassigned
                Reporter:
                price Paul Price
                Watchers:
                Hsin-Fang Chiang, Jim Bosch, Kian-Tat Lim, Paul Price, Tim Jenness
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:

                  Summary Panel