Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-3439

Rename ingest.py to reduce confusion with database

    XMLWordPrintable

Details

    • 2

    Description

      The ingestImages.py bin script provides a camera-agnostic manner of creating a data repository (including a registry). The back-end code resides in pipe_tasks under the name ingest.py, and the IngestTask._DefaultName = "ingest", which means that configuration files in obs packages are also named ingest.py. This choice of name was unfortunate, as it may be confused with ingest of sources into the database. We should change the name to reduce this confusion, perhaps ingestImages.py like the bin script.

      Attachments

        Issue Links

          Activity

            dtaranu Dan Taranu added a comment -

            We (Nate & Chris M) vote yes.

            dtaranu Dan Taranu added a comment - We (Nate & Chris M) vote yes.
            price Paul Price added a comment -

            So can we abandon this, and simply let the confusion die with Gen2?

            price Paul Price added a comment - So can we abandon this, and simply let the confusion die with Gen2?
            jbosch Jim Bosch added a comment -

            Gen3 already calls its version "RawIngestTask", which I think is probably sufficient to avoid confusion.

            jbosch Jim Bosch added a comment - Gen3 already calls its version "RawIngestTask", which I think is probably sufficient to avoid confusion.
            price Paul Price added a comment -

            jbosch, does this still make sense in the context of Gen3?

            price Paul Price added a comment - jbosch , does this still make sense in the context of Gen3?
            tjenness Tim Jenness added a comment -

            price are we ever going to do this or should we abandon RFC-83?

            tjenness Tim Jenness added a comment - price are we ever going to do this or should we abandon RFC-83 ?
            price Paul Price added a comment - - edited

            Suppose I should RFC this... RFC-83.

            price Paul Price added a comment - - edited Suppose I should RFC this... RFC-83 .

            People

              Unassigned Unassigned
              price Paul Price
              Dan Taranu, Hsin-Fang Chiang, Jim Bosch, Kian-Tat Lim, Paul Price, Tim Jenness
              Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Jenkins

                  No builds found.