Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-3559

Implement improved Footprints

    Details

    • Type: Epic
    • Status: Done
    • Resolution: Done
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Epic Name:
      f16-drp-footprint
    • Story Points:
      60
    • WBS:
      02C.04.01
    • Team:
      Data Release Production
    • Cycle:
      Spring 2017

      Description

      In S15/DM-1904 we began a redesign of the Footprint API. We need to follow through and convert that to code on disk.

        Attachments

          Issue Links

          Stories in Epic (Custom Issue Matrix)

          Key Summary Story Points Assignee Status
           
          DM-9064

          Fix memory leak in SpanSets Persistence

          0.5 Nate Lust Done
           
          DM-8973

          Wrap new Footprints with pybind11 and create python unit test

          8 Nate Lust Done
           
          DM-9105

          Make SpanSet operator templates more generic

          2 Nate Lust Done
           
          DM-8608

          Make SpanSets Persistable

          2 Nate Lust Done
           
          DM-9996

          Review SpanSet & Footprint API

          2 Jim Bosch Done
           
          DM-9233

          Add default constructor to new Footprints

          1 Nate Lust Done
           
          DM-8693

          Wrap SpanSets class with pybind11

          6 Nate Lust Done
           
          DM-8108

          Update stack code to use new Footprint API

          14 Nate Lust Done
           
          DM-8107

          Implement new footprints based on API

          12 Nate Lust Done
           
          DM-8103

          Add method to find edge pixels to SpanSet

          2 Nate Lust Done
           
          DM-8102

          Introduce Set operations between SpanSets and masks

          2 Nate Lust Done
           
          DM-7177

          Document interface for new Footprints class

          8 Nate Lust Done
           
          DM-7176

          Create API for new Footprints class

          5 Nate Lust Done
           
          DM-7174

          Implement SpanSet intersection/difference functionality

          6 Nate Lust Done
           
          DM-7173

          Implement SpanSet Spatial Union

          4 Nate Lust Done
           
          DM-7172

          Implement SpanSet overlap tests

          3 Nate Lust Done
           
          DM-7171

          Document interface for SpanSets class

          5 Nate Lust Done
           
          DM-7170

          Implement Interface for SpanSets

          3 Nate Lust Done
           
          DM-7039

          Familiarization with Footprint redesign

          5 Nate Lust Done
           
          DM-3666

          Revisit Footprint design

          4 Jim Bosch Done
           
          DM-1596

          Clean up multi-component Footprints

          4 Nate Lust Done
           
          DM-2427

          Implement SpanSet applyFunctor methods

          3 Nate Lust Done
           
          DM-2426

          Implement SpanSet+ellipse operations

          2 Nate Lust Done
           
          DM-2425

          Implement SpanSet core functionality

          6 Nate Lust Done
           
          DM-8104

          Add SpanSet Functionality to find nearest SpanSet from a list and point

          2 Nate Lust Won't Fix
           
          DM-7175

          Create transition Footprints class using SpanSets

          4 Nate Lust Invalid
           
          DM-2424

          Create transitional duplicate of Span

          1 Unassigned Invalid
           
          DM-1129

          Span-based topological set operations for Footprint

          20 Unassigned Invalid

            Activity

            swinbank John Swinbank added a comment -

            Shifting this epic to Fall 2016:

            • Delayed due to focus on the HSC merge in W16;
            • Not in X16 since that cycle is dedicated to planning & recovering tech debt.

              People

              • Assignee:
                nlust Nate Lust
                Reporter:
                swinbank John Swinbank
                Watchers:
                John Swinbank
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel