Uploaded image for project: 'Data Management'
  1. Data Management
  2. DM-35756

Support the PySide2 in Developer Image

    XMLWordPrintable

Details

    • Story
    • Status: Done
    • Resolution: Done
    • None
    • ts_main_telescope

    Description

      Please help to support the pyside2, qasync, and qt5-qtbase-devel in the developer docker image: lsstts/develop-env:develop. This is to support to run the M2 Python EUI under the QT framework (pyside2). The qasync is the repository to allow the QT application to use the asyncio in Python. These two modules can be installed by conda. The module of qt5-qtbase-devel is needed to run the QT in CentOS 7 (install by yum).

      I tried to demonstrate the above dependencies in the developer docker image. I entered the image by:

      docker run -it --rm -u root lsstts/develop-env:develop
      

      If I tried to use yum to install the qt5-qtbase-devel, I would get the following errors:

      [root@5c4ba225f2e2 ~]# yum install qt5-qtbase-devel
      There was a problem importing one of the Python modules
      required to run yum. The error leading to this problem was:
       
         /opt/lsst/software/stack/conda/miniconda3-py38_4.9.2/envs/lsst-scipipe-4.0.1/lib/liblzma.so.5: version `XZ_5.1.2alpha' not found (required by /lib64/librpmio.so.3)
       
      Please install a package which provides this module, or
      verify that the module is installed correctly.
       
      It's possible that the above module doesn't match the
      current version of Python, which is:
      2.7.5 (default, Aug  7 2019, 00:51:29) 
      [GCC 4.8.5 20150623 (Red Hat 4.8.5-39)]
       
      If you cannot solve this problem yourself, please go to 
      the yum faq at:
        http://yum.baseurl.org/wiki/Faq
      

      Please help to test and support the pyside2 in the docket image. You could use the QT example to check this can work in the docker image or not.

      Thanks!

      Attachments

        Issue Links

          Activity

            wvreeven Wouter van Reeven added a comment - - edited

            Note that the develop-env Dockerfile runs on AlmaLinux 8. This is why trying to install qt5-qbase-devel fails. When the PySide2 conda package is installed, no additional OS packages for QT are needed since they are included in the conda package. I tried installing the latest version of PySide2 (5.15.5) but the dependencies fail to be installed:

             

            $ mamba install -y PySide2=5.15.5 qt-main=5.15.3 icu=70.1
            __ __ __ __
             / \ / \ / \ / \
             / \/ \/ \/ \
            ███████████████/ /██/ /██/ /██/ /████████████████████████
             / / \ / \ / \ / \ \____
             / / \_/ \_/ \_/ \ o \__,
             / _/ \_____/ `
             |/
             ███╗ ███╗ █████╗ ███╗ ███╗██████╗ █████╗
             ████╗ ████║██╔══██╗████╗ ████║██╔══██╗██╔══██╗
             ██╔████╔██║███████║██╔████╔██║██████╔╝███████║
             ██║╚██╔╝██║██╔══██║██║╚██╔╝██║██╔══██╗██╔══██║
             ██║ ╚═╝ ██║██║ ██║██║ ╚═╝ ██║██████╔╝██║ ██║
             ╚═╝ ╚═╝╚═╝ ╚═╝╚═╝ ╚═╝╚═════╝ ╚═╝ ╚═╝
            mamba (0.24.0) supported by @QuantStack
            GitHub: https://github.com/mamba-org/mamba
             Twitter: https://twitter.com/QuantStack
            █████████████████████████████████████████████████████████████
             
            Looking for: ['pyside2=5.15.5', 'qt-main=5.15.3', 'icu=70.1']
            conda-forge/linux-64 Using cache
            conda-forge/noarch Using cache
            Pinned packages:
             - python 3.10.*
             
            Encountered problems while solving:
             - package qt-5.12.9-h1304e3e_6 requires icu >=69.1,<70.0a0, but none of the providers can be installed
             - package qt-main-5.15.3-hf97cb25_0 requires icu >=70.1,<71.0a0, but none of the providers can be installed
            

             

            So I used 5.13.2 instead, which installs fine. I also made sure that qasync 0.23.0 gets installed, which is the latest version.

            wvreeven Wouter van Reeven added a comment - - edited Note that the develop-env Dockerfile runs on AlmaLinux 8. This is why trying to install qt5-qbase-devel fails. When the PySide2 conda package is installed, no additional OS packages for QT are needed since they are included in the conda package. I tried installing the latest version of PySide2 (5.15.5) but the dependencies fail to be installed:   $ mamba install -y PySide2= 5.15 . 5 qt-main= 5.15 . 3 icu= 70.1 __ __ __ __ / \ / \ / \ / \ / \/ \/ \/ \ ███████████████/ /██/ /██/ /██/ /████████████████████████ / / \ / \ / \ / \ \____ / / \_/ \_/ \_/ \ o \__, / _/ \_____/ ` |/ ███╗ ███╗ █████╗ ███╗ ███╗██████╗ █████╗ ████╗ ████║██╔══██╗████╗ ████║██╔══██╗██╔══██╗ ██╔████╔██║███████║██╔████╔██║██████╔╝███████║ ██║╚██╔╝██║██╔══██║██║╚██╔╝██║██╔══██╗██╔══██║ ██║ ╚═╝ ██║██║ ██║██║ ╚═╝ ██║██████╔╝██║ ██║ ╚═╝ ╚═╝╚═╝ ╚═╝╚═╝ ╚═╝╚═════╝ ╚═╝ ╚═╝ mamba ( 0.24 . 0 ) supported by @QuantStack GitHub: https: //github.com/mamba-org/mamba Twitter: https: //twitter.com/QuantStack █████████████████████████████████████████████████████████████   Looking for : [ 'pyside2=5.15.5' , 'qt-main=5.15.3' , 'icu=70.1' ] conda-forge/linux- 64 Using cache conda-forge/noarch Using cache Pinned packages: - python 3.10 .*   Encountered problems while solving: - package qt- 5.12 . 9 -h1304e3e_6 requires icu >= 69.1 ,< 70 .0a0, but none of the providers can be installed - package qt-main- 5.15 . 3 -hf97cb25_0 requires icu >= 70.1 ,< 71 .0a0, but none of the providers can be installed   So I used 5.13.2 instead, which installs fine. I also made sure that qasync 0.23.0 gets installed, which is the latest version.
            ttsai Te-Wei Tsai added a comment -

            Please help to install pytest-qt as well by conda -c conda-forge to support the unit test of QT GUI. Thanks!

            ttsai Te-Wei Tsai added a comment - Please help to install pytest-qt  as well by conda -c conda-forge to support the unit test of QT GUI. Thanks!
            wvreeven Wouter van Reeven added a comment - ts_cycle_build PR: https://github.com/lsst-ts/ts_cycle_build/pull/144

            Reviewed on GH by tribeiro

            wvreeven Wouter van Reeven added a comment - Reviewed on GH by tribeiro

            People

              wvreeven Wouter van Reeven
              ttsai Te-Wei Tsai
              Tiago Ribeiro
              Petr Kubanek, Te-Wei Tsai, Tiago Ribeiro, Wouter van Reeven
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Jenkins

                  No builds found.